Web Socket Error on AmazonEchoControl binding every 65 seconds

Same here (Germany) also since this morning.

India same issue since last 2 weeks.

2021-10-10 22:40:19.760 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:40:37.765 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:40:55.720 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:41:13.088 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:41:32.253 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:41:50.093 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:42:07.938 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:42:25.505 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:42:42.453 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:43:00.496 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:43:17.637 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:43:35.069 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:43:52.648 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:44:09.384 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:44:26.288 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

2021-10-10 22:44:44.098 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

same here
Stopped Amazon Echo Bundle, let’s see…

Also in Spain…

I think Amazon changed something on their side (maybe API changed)?

Exactly.

Same here (Germany) :frowning:

I lost “LastVoice” functionality and started seeing 1005 error on Oct 8 2021. It hasn’t come back on its own.
Still a problem after updating to openhab “3.1.0 - Release Build” along with
Active 3.1.0 openHAB Add-ons :: Bundles :: Amazon Echo Control Binding
(deleted /cache, /tmp and restarted too)

As someone posted previously, the API is still returning the info, so does that point to a fixable problem (not on Amazon side, but on openhab binding side?)
http://[x.x.x.x]:8080/amazonechocontrol/account1/PROXY/api/activities?size=5&offset=1

{"activities":[{"_disambiguationId":null,"activityStatus":"SUCCESS","creationTimestamp":1633973046694,"description":"{\"summary\":\"alexa what time is it\",...

(when I say “alexa what time is it”, this appears in the API, so why shouldn’t the binding be able to set the LastVoice variable to it?)

We are working on it.

12 Likes

Hi,
I’m quite new to openHAB and have same problem. I still have version 2.5.10 of Amazon Echo Control Binding installed and also openHAB 2.5.10 (on raspberry pi wheezy). I assume if this problem will be solved, it will happen with the newest release or? Can I installed this repaired binding even I will not update openHAB? I’m afraid of install new openHAB version, because it took me a long time to get it running and telling me local raspberry pi variables on request (like temperature, voltage etc.) on verbal request to echo.

1 Like

I‘ll provide fixed versions for 3.0/3.1/3.2 but codebase is too different to create a fix for 2.5.

3.1/3.2 will be available this evening, 3.0 in the next days.

4 Likes

Where will be the download place for the fixed binding ?

Is there any chance to get a fix for 2.5 in the future?

2 Likes

Instructions:

  • Uninstall amazonechocontrol binding (important, you’ll run into all sorts of trouble if you run two bindings at the same time)
  • Download the updated addon (see below)
  • Drop downloaded file in your addons folder

For openHAB 3.1.0 (M5 or release) and 3.2.0 (before M3): removed
For openHAB 3.0.x and 3.1.0 (M1-M3) : removed
For openHAB 3.2.0 (M3 and later): removed

In case of any problems: please provide a DEBUG level log of org.smarthomej.binding.amazonechocontrol.internal.websocket via PM to me (publishing here could reveal your Amazon customer id).

Regarding 2.5.x: Not from my side. As I said above: The code base (especially for the web socket part) is IMO too different for backporting.

10 Likes

There was a developer who fixed the authentication issues earlier this year that was part of release 2.5.13 somewhere on this forum. Ideally if we can find this person, we can get this fixed for the 2.5.x folks.

@michi , maybe you can help or know the last person that updated the binding?

Best, Jay

Hi @jlekhter , can you help us with a 2.5.13 version fix to resolve last command channel throwing errors now?

Best, Jay

1 Like

Thanks a lot! Works again for 3.2.0 M3.

1 Like

I thought oH 2.5.12 was the last version of 2.5 branch?

Thank you for your fix.
But with the new binding, the announcements do not work anymore…
can anybody confirm this?

Here’s the 2.5.13 but does have the issue reported on this thread.

Best, Jay