Amazon echo control: guest wifi toggle (fritzbox)

using OH 4.1.1 with amazon echo control binding and fritzbox (TR064) binding.

So I have a switch item “Wifi_Guest”, which triggers the TR064 command to toggle the guest wifi. Works as designed.

But: If I give it the name “Guest Wifi” (or german “Gäste WLAN”), my Alexa won’t recognize the command. If I name it something else it works as expected.

Is there a conflict between some alexa hard-wired names and my own naming? Could I solve this somehow?

maybe call it Trittbrettfahrerdaten

my guest wifi is named “Skynet”, so this is the name atm. But: I don’t think I remember that in three days and I (and my family) will try with “Alexa, turn on ‘guest wifi’” - and it will fail… :wink:

I would assume that from Alexa perspective this is just a regular switch that can be turned on and off.

Have you checked the activity history via Alexa app, if Alexa maybe misunderstood your command?

Yes, I see this multiple times. with the “w.lan” instead of “wlan” (sorry, german only)

the name of the device was “Gäste WLAN” in openHAB and in the Alexa App.

it translates:
→ “alexa, turn on guest wifi”
→ “sorry, what device?”

I would assume that for Alexa “wlan” and “w. lan” are different.

I would try to rename the switch in the Alexa app to “Gäste W. LAN”

of course! :roll_eyes::grinning::see_no_evil:
Thanks, that did the trick!