Amazon Echo Control Issue - Alexa Speak does not work (anymore) for a SONOS One speaker


I am having an issue with the Amzon Echo Control Binding. Since an upgrade to the latest openhab version the TTS functionality stopped working on my Sonos One with Alexa.

I have removed all items, things and uninstalled the binding. Deleted the cache and restartet openhab. Still I am not able to make the Sonos One speak the given text. I have an Echo Dot in my household that works fine.

I noticed that even after trying to clean the system and doing a fresh installation of the binding the Amzon Echo Control I see some left overs of my former configuration. After doing a “fresh” installation of the binding I navigate to http://openhab:8080/amazonechocontrol/ to configure the account and there I see that there is still a Think associated with the problematic device. When I try to remove the Thing I get an error “409 - Conflict” within PaperUI

Does anybody have a hint what I could do to fix this?

As I did not find any errors or warnings in the logs even on DEBUG log level I think the best approach is to do a fresh installation of the binding.


I have the same issue …no tts on Sonos

So TTS has been working for you? I just configured the binding and connected my Sonos devices manually. Looks mostly fine, but TTS unfortunately isn’t working.

I had previously used the voice or sound ouput on the Sonos devices using “playSound” or “say” command in rules, but this stopped working more or less after upgrading my Sonos system to “S2”. Still not sure if that update might be the reason behind it.

For me it used to work for many months already. Then it stopped suddenly. At a later point in time (after I opened this topic) it worked again for a short period of time and now it is also not working.

Will most probably try the Sonos TTS node with node red once I find the time.

What TTS service are you using? My VOICERSS is working fine (Sonos Play:1 S2)

I have tried now Polly TTS but the quality of the voices does not match the one from the original Alexa (my wife complaint about it :slight_smile: ). Too bad the original feature does not work anymore for Sonos. If someone finds a fix please let us know.

Note that TTS via openHAB is not ALEXA! Since ALEXA is build into the SoneOne, this voice should be working, however it will not work as the TTS service from openHAB.

Did anybody get this working?

TTS working just fine on “real” echo devices, but it does not work on my sonos ones.
Checking the capabilities list of my sonos devices under http://openhab:8080/amazonechocontrol/ , i see that it says reminders. However, they always play on one device, no matter which one i use in my rules, output is always on the same.

Does changing the config of the things(serial numbers) require some flush or restart of openhab?


just as info I’ve tried it today with the Amazon Plugin adding a beam Manually.
It’s shown as online but has no functionality.