Amazon Echo SmartJ Binding Last Voice Command not working anymore

As I already said: I need the response to /alexa-privacy/apd/rvh/customer-history-records. If the information cannot be seen from that response, we can’t do anything. Please send it to github@klug.nrw

Or added as a feature :slight_smile:

1 Like

@J-N-K Saved the response that you needed and send the email with the log. Let me know if I should do anything else.

@J-N-K

More debugging on this, I’m seeing this message sometimes on the OH Admin channel for lastVoiceCommand for my Echo (not the dot) when I actually asked for → TV Off <–.

Is this message baked into the code somewhere?

→ alexa yeah it is right now ←

My device isn’t even called Alexa, it’s called Echo so not sure where this is coming from?

Best, Jay

Yesterday i had to reboot the NanopiNEO3 because there was an update.
After the reboot TTS start to work again!!!
But last voice command works very strange way…
yesterday seems that was not working (i have covid again so no many energies to check)
today worked… but i was in my room and i get answer from bathroom…
But was sure that was the echo in my room that get the command because i have a routine that do a sound when echo receive this command (to avoid that alexa answer “i dont understand”) and the sound came from Echo in my room…

Hi,

I implemented a workaround which principle is explained here:
This is neither pythonic nor openhabic but at least it works :woozy_face:

I have looked into that. It’s quite interesting, because you can see what items are added or removed from lists (e.g. your shopping list). I just don’t know a good way to present these things in openHAB, because we don’t have an item-type for lists.

I thought about a use case, but I didn’t found any. A first step could be to make a readable log entry.
There could also be channels like LastAddedListItem and LastRemovedListItem for using in rules. I am convinced that there is someone who can do something useful with it.

It would be good, if you provide this version directly in the 3rd party add ons.
After updating to M4 LastVoiceCommand stopped working. I did all know steps to get it up. Nothing helped. Because of the rrd4j issue I downgraded to M3, but it didn’t solve it. Since two days I had no success with LastVoiceCommand. I set up a separate installation only for that. Also no success. Right now I saw that there is a newer version available, but that was no more in my mind. So I did the update. Because of several unusual log entries, I restarted openHAB and everything worked again.
I think you understand my suggestion. :slight_smile:

1 Like

Friday or Saturday :slight_smile: It’s already merged, I just need to do the release.

3 Likes

In our short email conversation we found out how to filter it, right?

I was just wondering if I can do the filtering myself via a rule or if that needs to be done in the bindings code. (Not a programmer/developer, so please excuse it if the question is stupid)

1 Like

I don‘t think you have access to the necessary information in a rule. Yes, your logs were very helpful.

1 Like

Alright thank you for the quick response and clarifying that it can not be done by rule. Will be patiently waiting then.

I there,

the lastVoiceCommand does not work again…

I use the following version of the binding:

316 │ Active │ 80 │ 4.1.0.202311121746 │ SmartHome/J Add-ons :: Bundles :: Amazon Echo Control Binding

with OpenHAB 4.1 M4

Has something changed again?

@J-N-K

Just do this:
update org.smarthomej.binding.amazonechocontrol https://download.smarthomej.org/org.smarthomej.binding.amazonechocontrol-4.1.0-SNAPSHOT.jar

@J-N-K Do you know, when you will find time to release the new version?

2 Likes

this has worked! thank you!

2 Likes

For OH4 I have already released 4.0.2 which contains all the fixes. For 4.1 the fixes are included in the latest snapshot, but I can’t do a release before the OH 4.1 release. Artifacts on Maven Central can’t depend on non-release artifacts.

When I download the snapshot over https://download.smarthomej.org/addons-beta.json which leads to https://download.smarthomej.org/org.smarthomej.binding.amazonechocontrol-4.1.0-SNAPSHOT.kar, I get the version is from the 12th of November. That version has the bug with LastVoiceCommand. The update (https://download.smarthomej.org/org.smarthomej.binding.amazonechocontrol-4.1.0-SNAPSHOT.jar) from the 27th November is working very well.
So I think, it would be great, if you provide the actual version as a snapshot via https://download.smarthomej.org/addons-beta.json
Of course a “real” release for 4.1 can not be present before 4.1 is released. I like working snapshots much more, than not working release builds. :wink:

Will the 4.1 version include the filtering that only the device that was actually spoken to will be updated?

(Maybe a stupid question but when is the release of 4.1?)

1 Like