Amazon Echocontrol - SmartHomeDevices not updated

  • Platform information:
    • Hardware: Raspberry 3B
    • OS: raspios-buster
    • Java Runtime Environment: Zulu 8
    • openHAB version: 2.5.10

Hi all, I’m getting crazy with the fact that in PaperUI or Sitemap I cannot update light switch status for all the SmartHome Devices imported via echocontrol Bindings.
All Items works if I send a command from OH PaperUI or Sitemap.
If I send a command via Alexa or from the real world bu manually toggling the switch, I cannot see any update on OH and not even any log of the event.
All items are lights belonghing to LivingNow and are imported to openhab with the following “travel”:
Legrand to Alexa --> Legrand Skill
Alexa to OH --> Alexa echocontrol Binding

My Things configuratiion is the following:

Bridge amazonechocontrol:account:xcxcxcxc "Amazon Account" @ "Accounts" [discoverSmartHome=0, pollingIntervalSmartHomeAlexa=30, pollingIntervalSmartSkills=120]
    Thing smartHomeDevice  Hallway_Light "Smart Home Corridoio" @ "Corridoio" [id="SKILL_xxxxxx"]

I tried all the discovery options 0-1-2-3 and nothing change.

My tipical Items configuration is:

Switch          Hallway_Light           "Luce Corridoio"               <light>           (Hallway, gLight)           ["Lighting", "Switchable"]   {alexa="disable",channel="amazonechocontrol:smartHomeDevice:xcxcxcxc:Hallway_Light:powerState"}

I tried with and without item tagging and with autoupdate= true or false and nothing helped.

I really do not know what to try further. The only thing that seems to work is to use a command refresh but this is a workaround with several drawbacks and rules implication.

According to Binding Description
the Binding provides features to control devices connected to echo and receive the current state of the lights.

What am I doing wrong ?

Nothing. There was a bug that should be fixed now. In 2.5.11-SNAPSHOT.

1 Like

Thanks very much ! I was really getting mad.
I’m a beginner with OH so could you link me to find the right way to test 2.5.11-SNAPSHOT ?
May be it is sufficent to rename the old jar and replace with the new one but I’m confident there is the right post with a how to :wink:

I have installed the new 2.5.11-SNAPSHOT
openhab> bundle:list -s | grep echo 274 x Active x 80 x x org.openhab.binding.amazonechocontrol
New SNAPSHOT works fine … it takes a bit for updating but WORKS ! :slight_smile: Thanks for the assistance.

1 Like

Hi Matteo,
I’m having the same problem. Where/how did you 2.5.11-SNAPSHOT?

You have to download the .kar (zip) file and look inside.

Or even better:

Then the procedure is easy: