AmazoneEchoControl Binding Accout connection Error

So noticed this in the last 24hrs.
My echo devices would not announce messages from OH anymore.
I have just done my initial investigation and it looks like the account thing was disconnected/logged out.
I deleted the account thing and then added a new one.
I tried to use the install steps and go to http://openhab:8080/amazonechocontrol/
which redirects from openhab to amazon site and it took me through a loop or two of incorrect password and you need to do a OTP.

I abandoned the redirect and went in my chrome browser and went directly to and after performing the OTP reset password could logout and log back in with the new password. I then tried same thing login to my local echo hub. and it worked. Great I thought making progress.

Going back to the redirect offered through openhab amazonechocontrol binding I tried to login and it say failed incorrect username or password. I had carefully typed these in so currently thinking amazon no longer accepts the redirect to login.

Is anyone else having issue in this space or is it my local issue?


Amazon changed the login, most of the discussion is in this thread, check the newest ones:

You need to have a recent binding version.


Thanks, used the snapshot jar and reconnected my account bridge to the echo device things and all is now working again.

1 Like

Don’t forget to mark @sihui post (click the square box) as the solution. :wink:

I actually answered through email so was not able to accredit correctly, but thanks for the chase and keeping my in honest.