Android App 2.1.0 - Notification sound

I upgraded the app to 2.1.0 (20 April) because thought it might have been the reason I was not receiving notifications. Turns out the lack of notifications was due to another reason Notifications Disabled

Now that that notifications are working again, I am at a loss to understand why my Samsung S4 is no longer giving a notification sound when a notification is received. I haven’t been able to test on another android yet.t

Is this a 2.1.0 problem, or have I missed a setting option. I didn’t have any problems with the older app

No solution from me, sorry for that, but a question.
How did you setup your system to react on notifications?

You can choose the notification sound in the app settings. Can you check if it’s set to “None”?

Me stupid, I misread the post and got to the false impression that he got a sound played on a separated sound system.
Sunday morning in Scotland, I should have slept longer.

No, the notification sound is set appropriately and the app is also set to receive notifications as a ‘priority’ application. Setting to ‘priority’ should not be relevant because there are still no sounds outside of my ‘do not disturb’ times. I never had any problems before the update.

At the risk of mixing another potential feature problem with this release (rather than creating a new thread), I’ve also noticed that the time stamp on the notifications have been changed in functionality. Before, there was a time of when the notification was sent, and a time when the notification was received. These times are now always the same, being the time the notification was sent, and ideally, should be reverted to the old method.

If I don’t have mobile data active, I wont receive any notifications,but when I get home and back onto wifi, all the messages will come through, and before, would have a ‘delivery time’ stamp.

I wish there were a way to roll back app updates.

Indeed, the timestamp has been changed to the time where the google server receives the notification. However there should only be one timestamp. Can you post a screenshot?

Oops - my bad - the ‘second’ timestamp is generated by my notification.

As you can see in the image, all my notification times and the timestamp are the same. However, all these notifications were delivered / received at the same time when I reconnected the device to the internet.

I believe the timestamp should reflect the delivered time, consistent with SMS message time stamps. Alternatively, this could be a setting and the user can decided what they prefer.

I’m still not getting any sounds with the notifications - any other ideas? I might have skipped a few updates and maybe there was a client side app change some versions ago that may be the cause. Unfortunately, I do not know what version I updated from

The timestamp should be the time when the event happens. You can see the same behavior on messenger apps.
The reason why it’s the delivery time at sms is (I guess) because sms don’t have enough metadata to know when the message was sent.

I just tested and I hear sounds. I’m having a look at the code. Skipping updates shouldn’t be the problem.

Further testing shows that I can get a sound when the notification arrives when I set the ‘Ring Tone’ in the App’s settings. I misread your original query, thinking that you mean ‘phone settings’, not app setting (as you clearly stated). Was this changed/added at some stage?

If so, then it seems different to the way the notification sound used to work. I thought the notification sound used to be the sound set in the phone’s settings.

The ‘Ring Tone’ settingalso had me confused with ‘notification sound’, as I saw them as being different things.

There was a bug where a sound was played even when it was set to “Mute”. This was fixed in 2.1.0

Indeed, I propose a PR to change “Ring Tone” to “Notification Sound”.

Thanks for your patience, assistance, and a great app.

1 Like

Which android version and device do you use? The orange background in the notifications are not looking good.

I’d suspect Samsung stock ROM, and the orange likely is our theme color.

Samsung Model GT-19507 (Optus Galaxy S4)
Android Version 5.0.1
Build LRX22C.19507XXSHPL1

I did notice the change in icon to orange, and is is almost unreadable on the home screen of the device using the default ‘blue’ colour. This was not the case with the old icon.

Some other observations and thoughts on the notification sound.

  1. the first option in the app’s ‘ring tone’ settings is ‘default ring tone’, however, perhaps this should be ‘default notification tone’. (or provide both options)
  2. whilst I don’t have a particular requirement at this stage, a possible enhancement might be to define custom notification tones in the app that could be sounded depending on the notification message. (ie from openhab, sendNotification(user, message, [notification tone ID]) )

You’re talking about ?

I have no samsung device, so I cannot test changes. What if we change the icon used for notifications to white?

Yes, I’m talking about exactly that one. And yes, notification icons are supposed to be entirely white. See the ‘notification icon’ section here:

@ray Can you try the apk uploaded here and make a screenshot of the notifications?

Will let you know how this goes. After having the “apk app not installed” message and having to uninstall the original app, I am now having the dreaded problem of the device not registering in myopenhab, despite confirming correctly username/password; deleting and recreating user, rebooting etc.etc. Not the first time I’ve this problem, but finding the method to fix is the challenge. I don’t know what I did to fix the problem the last time around.

This is because my apks is signed by my debug key and releases are signed by the release key. Android does not allow to update when the signature changes.

How do you know that it does not register? Any error messages? What shows the “Push notification status” in the about screen?

Never thought of looking there. It says - ‘Device Registration Failed’, but I could see that the device was not showing up in

Here’s what I find.

  1. When installing the apk (after deletiing the old one play store app) and sending a notification, nothing came through to the Samsung, so:
  2. I then logged on to the userid for the phone on, and then deleted the device
  3. I then tried to register by trying a number of things on the phone, including changing the userid to an invalid one, and then setting the correct one; restarting the phone. etc
  4. I tried deleting the user id in and recreating
  5. I believe the phone is connecting correctly (ie correct userid/passowrd), since the remote URL connection works, however, the device never shows up in
  6. I also can see when I log on to the same userid in that the notifications are being received by the cloud.
  7. The notifications received by the cloud are not being pushed to the phone, since the device is not showing as being registered in

(Sorry that this is now off topic)