Android App Beta

android
Tags: #<Tag:0x00007fe057ff0368>

(Michael Joos) #21

Connection from remote (myopenhab.org) doesn’t work for me with this apk.


(Mueller Ma) #22

Can you remove the local url, enable debug mode and post the error message here?


(Michael Joos) #23

I do not get any error message. The circle is just running all the time:


(Danny Baumann) #24

@michaeljoos Is your device rooted by any chance? If yes, can you grab logcat output using the app ‘MatLog’ after this happened? (And if no, could you install / have you installed the Android SDK tools to grab logcat?)

@mueller-ma I guess we need to implement sending logcat via email at some point…


(Michael Joos) #25

It’s my business phone…root is not possible. Do I have to install the SDK-Tools on my computer and then connect the phone or is it an Android-App?


(Danny Baumann) #26

It’s a PC application which connects to the phone. In Linux distributions it’s usually packaged already (named android-tools or the like), for Windows there’s e.g. https://www.google.de/amp/s/devsjournal.com/download-minimal-adb-fastboot-tool.html/amp (googling ‘adb windows minimal’ reveals plenty of additional instructions).

Logs can be grabbed after installing and connecting adb by running ‘adb logcat’ after reproducing the issue and sending the output of that command to us.


(Danny Baumann) #27

Thanks @michaeljoos for the log. It looks all fine until creating the data loader for the first page, but then there is no output anymore which means the data loading fails. I’ll have to add some more log output and ask @mueller-ma to do a new beta release before we can get to the bottom of this :-/


(Markus) #28

I have the same issue like @michaeljoos with the new beta. If you need more logs, i can provide my output too.


(Danny Baumann) #29

@michaeljoos @wislander I’ve built a version with more debug output: https://www.dropbox.com/s/xpc5wxbe0xmnr3k/mobile-foss-debug.apk?dl=0
As I don’t have the official signing keys, I’ve given it another package name and added ‘Debug’ to the app name to make it distinguishable. Please let it run and send new logcat. Thanks!


(Danny Baumann) #30

Thanks to @wislander’s log I now know what’s wrong: authentication is missing when loading data. I’ll fix this.


(Danny Baumann) #31

https://github.com/openhab/openhab-android/pull/768 should fix it.


(Hallo Ween) #32

Where can I download new APK? On GitHub release page there are no apk’s for the latest versions anymore. Only source code.


(Mueller Ma) #33

It takes some time until the apks appear there.
One travis build takes about 20 minutes. The android tests fail quite often, so I have to restart the build (additional 20 min). And there was an issue with the automatic version bump, so additional 20 min.


(Mueller Ma) #34

I build the apk manually: https://github.com/openhab/openhab-android/issues/549#issuecomment-372021242


(Mueller Ma) #35

You can now download the official build (with updated version number in the about screen): https://github.com/openhab/openhab-android/releases/tag/2.0.25-beta


(Hallo Ween) #36

I installed the latest version, 2.0.26a and I can confirm, that remote connection works now.

The app is faster then the last stable release. Great improvement! Thanks for your work!


(Markus) #37

The issue is gone and the app works like a charm. Thanks for the fast fix.


(Hallo Ween) #38

I wanted to install the 2.0.30 and now i get two installations on my smartphone side by side.

One is called openhab (with all my old settings) and the new one is openhab beta (with no settings).

???


(Mueller Ma) #39

I added “.beta” to the package name for beta builds and now both (stable and beta) can be installed alongside.
See https://github.com/openhab/openhab-android/pull/774


(HomeAutomation) #40

I tested it today. Is there a way to change fonts size? All my sitemaps are too big and not fully shown. Only in landscape view I can use it, but not all is shown too. See some examples below.

Portrait view:


Landscape view


I use 3Hou.se APP at the moment it this APP solved it in a good way. But has some other bugs. I use all two at the moment in parallel