Announcing openHAB 2.2

Hi Rich,

Thanks for he reply. I did opt for the default of keeping the original config files so it seems self inflicted!

Any idea how I can recover from this?

Regards

roy

I think there will be a version of the file in your /var/lib/openahb2/etc folder you can copy over.

Or you can use the example that Dim posted in the link KidSquid posted.

Hey, guys, just update on rpi3 (openhabian) appeared to be working but web interface doesn’t come up log shows the following:

2017-12-19 19:23:18.026 [ERROR] [org.eclipse.smarthome.io.webaudio   ] - FrameworkEvent ERROR - org.eclipse.smarthome.io.webaudio

2017-12-19 19:23:18.039 [ERROR] [org.eclipse.smarthome.model.core    ] - FrameworkEvent ERROR - org.eclipse.smarthome.model.core

2017-12-19 19:23:18.067 [ERROR] [org.eclipse.smarthome.model.rule    ] - FrameworkEvent ERROR - org.eclipse.smarthome.model.rule

2017-12-19 19:23:18.088 [ERROR] [eclipse.smarthome.model.rule.runtime] - FrameworkEvent ERROR - org.eclipse.smarthome.model.rule.runtime

2017-12-19 19:23:18.100 [ERROR] [org.eclipse.smarthome.model.script  ] - FrameworkEvent ERROR - org.eclipse.smarthome.model.script

2017-12-19 19:23:18.120 [ERROR] [lipse.smarthome.model.script.runtime] - FrameworkEvent ERROR - org.eclipse.smarthome.model.script.runtime

2017-12-19 19:23:44.936 [ERROR] [ternal.service.BootFeaturesInstaller] - Error installing boot features

A restart did not fix the issue

Hi Rich,

Thanks, followed kidsquid link and copied that file logging is now working!

I’ll now be able to check for any other problems…

Regards

Roy

Great work everybody! From a technical point of view, OpenHAB still is the most elegant DIY home automation platform out there! :slight_smile:

2 Likes

Congratulations on the milestone. As a Beginner in this type of activity, I really appreciate the voluntary contributions by so many folks who are able to stay aligned to the vision and guidelines of primary developers. Helps us novices to climb the learning curve in a slow but sure manner.

A very big THANK YOU to all concerned.

1 Like

Good work, upgraded from OH2.1 to 2.2 on an OpenHABian installation without any problem, THANKS to everybody involved.

2 Likes

Yes, I echo the other commenters and am very grateful for the diligent work of the maintainers and other contributors. openHAB has greatly matured even in the last year I’ve been using it.

2 Likes

Update from openhab 2.1 to 2.2 worked perfectly with apt within openhabian.

Had to put in the extra java opts for pointing to the zwave stick but that was it.

Rules worked fine, and with the new vs code plugin, it helped me fix an syntax error in my rules.

And, now the ikea trådfri color bulbs work, woo-hoo!

Thanks for all the work you guys and girls put into making OH.

4 Likes

As I am using only the snapshot runtimes, do I miss something regarding the 2.3 snapshot bindings?

https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastSuccessfulBuild/

Did they move to another place?

Beautiful! How I can use or install Home Builder?

Great to see this release!

Just one remark, the link in the docs of windows still points to the (now) old release of Openhab 2.1.0.

One of the new features that missed the release notes, and fills a big gaping hole in the DSL, is triggeringItem

2 Likes

Thx, 2.3 snapshots are available now, up and running again :rofl:

1 Like

@SepuGian

PaperUI --> Add-ons --> User Interfaces --> Home Builder --> Install

or

.\conf\services\addons.cfg

ui = homebuilder

How to use it:

Hi,

Thank you guys for your hard work!

I was hoping for any news on the homekit-binding and an opportunity to expose roller shutters, but, it seems, that there’s no step foward. Are there any further plans on this topic?

Regards, Speedy

1 Like

Thank you, I have updated yesterday openHab to 2.2.0 Release (Mac OS X) but in paperUi -> add-ons -> I have only 3 tabs: Bindings, Misc and Voice.

Hmm, I don’t know this issue, maybe there is a difference to Mac OS X version. (I use Windows 10)

Mine is looking (since a very long time) like this:

But you can also try:

.\conf\services\addons.cfg

ui = homebuilder

1 Like

C:\OpenHAB_2_2>start.bat
Launching the openHAB runtime…
-Djava.endorsed.dirs=C:\Progra~1\Java\jdk-9.0.1\jre\lib\endorsed;C:\Progra~1\Java\jdk-9.0.1\lib\endorsed;C:\OpenHAB_2_2\runtime\bin…\lib\endorsed is not supported. Endorsed standards and standalone APIs
in modular form will be supported via the concept of upgradeable modules.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

I did a fresh Win10, JAVA 9, OpenHAB 2.2 install and got the following error above. Any idea?

Reading the docs would give that explanation:

As for now, a pre-release Java 9 installation is not recommended and is not yet supported by openHAB 2.