Announcing openHAB 2.2

Dear all,

After the annoucements of the new native iOS & Android apps and the new release of openHABian yesterday, I am very happy to add the news about the openHAB 2.2 release here!

You can find the detailed release notes on Github and as usual, I have written a short blog post about some of the highlights of the release.

Enjoy the new release and keep coding for 2.3 now! :slight_smile:

P.S.: If you come across any issues, please directly files bug reports in the corresponding issue trackers - this will make it easier to follow-up than using this topic here.

Cheers,
Kai

58 Likes

Thanks and great job everyone! :trophy:

Will we also be able to enjoy it on Docker? :whale2: Is someone still working on that? :smile:

1 Like

Looks like it: https://github.com/openhab/openhab-docker/pull/129

1 Like

Thanks a lot to everyone being involved in OH.
I really appreciate all your efforts enabling me with my limited coding capabilities to create a very satisfying smart home.

Keep on going :slight_smile:

1 Like

how to upgrade from OH 2.1 to OH2.2 in linux

Take a look here:

http://docs.openhab.org/installation/index.html

You need to find the platform specific docs for your hardware :rofl:

Now we are desperately waiting for the 2.3 snapshot bindings availability :sunglasses: :thinking:

1 Like

Heise Developer already published an article about the new release focusing on Visual Studio Code support: https://www.heise.de/developer/meldung/Smart-Home-openHAB-2-2-oeffnet-sich-weiter-fuer-Visual-Studio-Code-3920873.html (German)

1 Like

I’m super excited that we reached that milestone! :champagne: :trumpet::trumpet::trumpet:

Will prepare a post with HomeBuilder presentation shortly, so everyone can enjoy it and kickstart their automation :slight_smile:

Just to let you know real quick - if you have any ideas on how to improve HomeBuilder, feel free to submit an issue and CC my github handle (same as here).

Congrats everyone!

5 Likes

Is there already a process regarding these 2.2.x updates? It probably warrants its own topic/FAQ/Wiki so it can answer questions like:

  • Will this be done with additional 2.2.x release branches now master branches are 2.3.0-SNAPSHOT?
  • Should contributors also create PRs to get code merged in these branches?

Note that the upgrade process with Docker is not as smooth as it should be. I use the following process:

  • Backup and delete the contents of userdata
  • Run the new Image
  • Wait for OH to come up. Notice that userdata has been repopulated.
  • Stop the container
  • Restore userdata/jsondb and any modified config files in userdata/etc that you may have modified. It is probably best to reedit those files rather than blindly copying them.

We have a concept that might work to automate this but I haven’t had a chance to work on it to prove it out. The concept is to modify entrypoint.sh to check userdata/etc/version.properties and if the default version is different from the one mapped into the container then essentially do the same steps as Benjy’s script/apt-get/yum upgrade process. I know it is all theoretically possible but my Bash scripting skills are not all that great these days.

4 Likes

No, this is something we want to work out after christmas. But yes, the rough plan is to have 2.2 branches from which such releases would then be built. We do not have those branches yet (only the 2.2.0 tags), so PRs cannot be created against it. Note that only really critical fixes should make it in there. I’d suggest to add a β€œcritical” label to the according issues/PR, but this is up to the maintainer - once the branches are created, those commits can be cherry-picked to it.

Leave us now a few days to relax, the past weeks (and night) were pretty tough :exploding_head:

2 Likes

Unless I have missed something, in looking at the upgrade instructions for Windows I can see there has not been a change since 2.0 stable came out.

If you are upgrading from one stable version to another there is an issue when following those instructions in regards to the new logger. If you do not remove/delete the current logging file and add in the new one your log files will be blank.

2 Likes

Nice. Thanks @ysc for the habpanel custom icons!

1 Like

Great work! The upgrade process was painless on debian :slight_smile: thank you!

1 Like

Fantastic! Another great milestone for home automation enthusiasts and users.
Congratulations and thanks a lot to all who have made this possible especially just before Christmas!

1 Like

I was able to upgrade to 2.2 on my RPi3, but because I had to install Oracle JDK version of Java to get it to work with openHAB cloud, I’m now getting errors when running β€œsudo apt-get upgrade” where it’s wanting me to install or use the JRE or JDK that contains missing components… Anyone else have this issue?

If you are a Windows user you could think about adding that to the docs:

1 Like

Dear Kai,

Thank you and the team for this release.

I’ve upgraded v2.1 on a raspberry Pi3 using apt get. The installation went well and all appears to be working with the exception on a blank log file.

Having read the link below about a windows installation I stopped OH, deleted the log files and restarted. OH created openhab.log but it is still blank.

Below is the log list in case it might provide some insight. Any idea what I have done wrong?

Roy

openhab> log:list
Logger β”‚ Level
────────────────────────────────────────────────────────────┼──────
ROOT β”‚ WARN
javax.jmdns β”‚ ERROR
org.apache.aries.spifly β”‚ ERROR
org.apache.karaf.kar.internal.KarServiceImpl β”‚ ERROR
org.eclipse.smarthome β”‚ INFO
org.jupnp β”‚ ERROR
org.openhab β”‚ INFO
org.openhab.binding.zwave β”‚ INFO
org.ops4j.pax.web.service.jetty.internal.JettyServerWrapper β”‚ ERROR
smarthome.event β”‚ INFO
smarthome.event.InboxUpdatedEvent β”‚ ERROR
smarthome.event.ItemAddedEvent β”‚ ERROR
smarthome.event.ItemRemovedEvent β”‚ ERROR
smarthome.event.ItemStateEvent β”‚ ERROR
smarthome.event.ThingStatusInfoEvent β”‚ ERROR
openhab>

When you did the upgrade did it ask if you want to keep or use the new version of any config files? The logging config changed between versions and if you don’t have the new one your logger will be broken.

See @KidSquid’s posting above.