Another IDE Setup Issue

  • Platform information:
    • Hardware: i7-7700, 16GB RAM, 500GB SSD
    • OS: Windows 10
    • Java Runtime Environment: JDK-8u231 x64
    • openHAB version: 2.5
  • Issue of the topic:

Ever since the switch to BND, I have been very unsuccessful in getting the IDE up and running. As a result, I stopped all of my binding development (Hayward OmniLogix Pool Controller Interface), put the project on the back burner in hopes that it would improve. That was roughly 9 months ago when the weather was warming up. Now that winter is upon us, I’m ready to try again. In my latest attempt I installed eclipse per the instructions here. I selected the 2019-12 version and no other options other than the OpenHab Development environment. I left for a few hours and came back to a blank welcome page, but an IDE behind it that looked ok. The problem is it refuses to resolve and throws the following error:

Resolution failed. Capabilities satisfying the following requirements could not be found:
⇒ osgi.identity: (osgi.identity=org.openhab.ui.paper)

I’ve tried cleaning and rebuilding, which happens extremely quickly with no errors. Somewhat suspicious. If I try to run without a successful resolve, I get these errors

Status ERROR: bndtools.core code=0 Cannot find /error/org.openhab.ui.paper;version=[3.0.0,3.0.1) Not found in [bndtools.m2e.MavenWorkspaceRepository@144c92f3, bndtools.m2e.MavenImplicitProjectRepository@7f0a6a88, bnd-cache [C:/Users/Controls/.bnd/default-ws/cnf/cache/4.3.1/bnd-cache r/w=false]] null

Status ERROR: bndtools.core code=0 org.openhab.ui.paper;version=[3.0.0,3.0.1) Not found in [bndtools.m2e.MavenWorkspaceRepository@144c92f3, bndtools.m2e.MavenImplicitProjectRepository@7f0a6a88, bnd-cache [C:/Users/Controls/.bnd/default-ws/cnf/cache/4.3.1/bnd-cache r/w=false]] null

If I continue to run get this followed by tons of other errors.

! could not resolve the bundles: []

Welcome to Apache Felix Gogo

Any help would be appreciated. Hopefully I’m missing something simple.


Make sure that for the openhab-distro repository you have the 2.5.x branch checked out - not master as this is now being migrated to OH3 and will no longer work!

I’m trying to setup Eclipse, using the Eclipse Installer. I select advanced mode, and 2 Git repos.
openHAB Development and openHAB Add-ons.
I try to select “Stream” 2.5.x, but the dropdown just contains master.
After struggling with field master, I sometimes are able to enter 2.5.x as text, but then the installer terminates. I need some advice on how to select 2.5.x for binding development with Eclipse (2019-06).
Dev env is macOS Catalina

I have the exact same problems as Matt an Jan. Also trying to select 2.5.x from the installer - like Jan - but it is not possible.

Tried to download master (dist+addons) from the Eclipse installer, and then “git checkout 2.5.x” in both repos. I get everything to build from the command line (mvn install -DskipTests -DskipChecks) after that, but I can’t get it to pick up and run my binding.

Maybe those steps takes you closer as well?

Not sure if the FeatureInstaller error is expected or related to my new (and unaltered after the archtype script) binding.

2020-01-03 00:29:45.442 [WARN ] [org.apache.felix.fileinstall ] - A bundle with the same symbolic name (org.openhab.binding.nobohub) and version ( is already installed. Updating this bundle instead.
2020-01-03 00:30:25.363 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-package-standard’: No matching features for openhab-package-standard/0