(Another) Unknown Device, but with status ONLINE and in Device List

  • Platform information:

    • Hardware: Raspberry Pi 3 + Aeotec Z-Stick Gen5
    • OS: Raspbian
    • Java Runtime Environment:
      – openjdk version “1.8.0_212”
      – OpenJDK Runtime Environment (build 1.8.0_212-8u212-b03-2~deb9u1-b03)
      – OpenJDK Client VM (build 25.212-b03, mixed mode)
      – javac 1.8.0_65
    • openHAB version: 2.5.0 Build #1627 SNAPSHOT
  • Issue of the topic:

First, offtopic: I should start by saying that I am (very) new to this, only have some hours messing with Raspberry, Linux, openHAB, all together… never messed with any of these individually or like this. Although this was not hard for me, so far, since I know some programing languages.

Near finishing the challenge of building my “home sweet home” (almost a year and half already, and still some 2 months to go), I always wanted to put hands on and make my own home automations, so this is it. :slight_smile:

So, back to the topic! I was using openHAB v2.4.0 Stable, but when I tried to add a Simon IO: Roller Blind, it “discovered something” but was basically naming it as a Node 001, status was “OFFLINE - COMMUNICATION_ERROR” and therefore it was “seen” as an Unknown Device.

After a lot more hours searching, I ended up upgrading to the current openHAB v2.5.0 Build #1627 SNAPSHOT. It now shows status ONLINE but that’s it… everything else is the same!

I’ve noticed the item IS actually on the list of Z-Wave items from @chris ( right about here ) and I’ve also noticed when I was in OH 2.4 it showed manufactureID and now it doesn’t:

I already have a Light Switch from this same brand (Simon IO Switch) working perfectly but this Roller Blind, although it’s on the list, I am not being able to make it work.

Thank you so much in advance guys, I’ve already seen that this community seems great and that’s what I love in a community like this. :slight_smile:

Your device has a different device id than the one that is in the database. If it’s really exactly the same, then we can add it to the database. Can you confirm that it is exactly the same device as already in the database?

Hi Chris,

Thank you for your fast answer and availability.

How can I check device ID? Here’s the link for this device.

In properties, I only see “0” (as in the image above).

It is printed in the properties - it is 0.

This should be correct.

Hi Chris,

I was out of the country and with limited access to internet.

Now that I am back, I saw your answer but I still not quite understanding how can I make it work since it does not recognize the device.

Could you please help me out?

Thanks a lot once again!

Best regards,
Pedro

No - your device is not in the database, so it won’t work.

My question is if the device in the database that you referenced above is EXACTLY the same as the one you say you have? I can’t tell as the link is not in English, so you will need to check.

If it’s the same, then we can just add your devices type and id to the database. If it is not the same, then we need to generate a new database entry.

Hi Chris,

Thank you for your answer.

The exact component is this one here.

So this means the “Name” in here maches the “REFERENCE NO.” on the link above.

So yes, I would say this is the exact same device.

Thanks!

I’ve updated the database to reflect this - hopefully it should be available tomorrow (EU Time) or later tonight US Time.

Thank so much Chris. I am only available to try this in some 12 or 13 hours from now.

How can I update the database?

You need to upgrade your zwave binding to the latest snapshot:

https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles$org.openhab.binding.zwave/

1 Like

Thank you so much, will definitely try this later when I have the chance. :slight_smile:

1 Like

And there it is, it recognized the thing and it’s “doing something” (I hear the relay working at least).

The thing is, this appears as “Dimmer” instead of “Rollershutter”. Is it suppose to be like that?

I don’t have this yet connected to my rollershutter, but when I do I will test it and then leave here the final result! :slight_smile:

Thanks a lot guys. What a great community.

Nope, fixed.

I’ve updated and upgraded but still the same, suppose this takes some time so that I can get latest snapshot, right?

Database changes are merged into the zwave snapshot binding usually during the weekend, please watch the github repo, after you are seeing the changes there is a good chance to have them into the snapshot binding after the next successful build.


https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles$org.openhab.binding.zwave/

1 Like

Hi guys,

Ok, have updated and upgraded to latest snapshot from yesterday but the thing is still showing as Dimmer, instead of Rollershutter.

I’ve already reset the item and it was added as a new one but still when I go to Channels, it stills only recognizing as Dimmer.

Thanks!

The change made it to the zwave repo, but either the snapshot jar is not updated yet or you missed to delete the Thing and readd it:

 <channel id="blinds_control" typeId="blinds_control">

I was probably too fast upgrading it yesterday as soon as I saw it was updated on GitHub and at that time it wasn’t yet fully updated on openhab. :smiley:

I’ve just upgraded and now it’s recognizing as it should.

Problem now is, my unit is blinking rapidly and on their documentation that means an “Error” and therefore the connection is not working properly, but I have no idea why this is happening! :frowning:

Well, anyway, regarding OpenHab everything seems perfect now so I thank you guys very much for that. :slight_smile:

Make sure it is included properly and fully initialized.

I suppose it is everything ok regarding that because I could even connect this with Alexa and make it work, so I can only asume this is some problem with the product. Because even if I fully reset the device it still blinks with 0,1sec difference.

Anyway, so far so good with OpenHab, I’ve been able to setup everything and make it work with not that much effort.

So congratulations to everyone involved in this project. :slight_smile: