Anyone know how to setup broadlink sp4d?

  • Platform information:
    • Hardware: docker
    • OS: "Debian GNU/Linux 11 (bullseye)
    • Java Runtime Environment: openjdk 11.0.13 2021-10-19 LTS
    • openHAB version: 3.2.0
  • Issue of the topic:

i am very new to all of this so it may be lacking in information, please be explicit in any request for more info and i will grab it.

basically i tried to setup broadlink sp4d-us smart plug. i tried home assistant, domoticz, and openHAB. so far i like openHAB best but really none of them worked.

i found

but so far haven’t been able to get the jar installed.

i tried putting it in the addons folder and setting the ownership and permission to match. i tried creating and putting it into the sub ‘bundle’ folder and again setting the permissions and ownership to match.

The add-ons folder is the correct place. Did you restart OH after doing that? I can’t remember if it’s necessary, but as soon as OH picks up the binding, you should see it when you try to manually add things.

However, the SP4s isn’t in the list of available devices. You might be able to get it to work with another SPx device in the list. If not, you’ll have to submit a request to @themillhousegroup to add it to the binding.

thanks for the response,

i still can’t get it to work.

is there a log i can check to see if its trying to pickup the file and failing?

i just have the docker log, and the openhab.log nether say a thing.

may i ask which folder is the correct addons folder?


i tried both mind you but most recently i tried openhab/addons and i restarted like you had recommended (which i had already done) on my second or third restart the jar file disappeared.

not sure where it went, but maybe that means it tried to install and got deleted, or installed and i just can’t find where?

I believe it should be /openhab/addons, but I’m a little out of my element here. I’m using the openHABian image, and the file system may not be quite the same in docker. I don’t know why the jar file would have disappeared, though.

I don’t think bindings show up in the log, but I’ve honestly never looked closely.

Ideally, this binding would get added to the Community Marketplace so that you can add it through MainUI, but that obviously hasn’t happened yet. Sorry I can’t be of more assistance.

so i gave up for about a year after trying all the automations systems and all the ways to add incompatible devices to them. recently i had been trying again. at the same time the SP4D-US device had become unreliable. so i emailed the company hoping they would replace it. they offered to replace it with an SP4M-US so that i could use it in various automation systems.

so anyone doing a search on SP4D and you come across this like i did a year after having had created the original thread. unless you have programming experience better than the folks that created this software and/or the Broadcom hardware.might be best to give up and get something that is compatible.

I typically recommend TP-Link Kasa devices, which are inexpensive and easy to set up. Once they’ve been added to a TP-Link account and openHAB, they can be denied Internet access so that they’re only controlled locally by openHAB.