Aotec multisensor 6 doesn't pick up parameter changes

I am having the same issue of not being able to set the PIR sensitivity. I have the old 1.8.0-SNAPSHOT of the z-wave binding, I tried upgrading to the latest 1.9.0-SNAPSHOT. However my Habmin1 with Openhab 1.7 doesn’t seem to like it, I get stack traces in my logs. What combination of versions of each item do I need to get this working? Sorry if this is a newbie questions but so much of this is new to me. Thank you all for your great work on this project.

I solved my own issue by replacing the appropriate .xml file in the database folder inside the 1.8.0-SNAPSHOT with the version in 1.9.0-SNAPSHOT.


replacing the appropriate .xml file in the database folder inside the 1.8.0-SNAPSHOT with the version in 1.9.0-SNAPSHOT

how did you you do this?

I tried to do this, too. I used 7-zip to overwrite products.xml and in my case to add everspring/hac01.xml to org.openhab.binding.zwave-1.8.1.jar. But with the updated jar file the zwave binding does not start.


I’m on Windows so I used WinRar to open the .jar file and within WinRar I deleted the old database/aeon/zw100-a.xml file and then pasted in the new version. I used the commands within WinRar to do this as opposed to extracting and re-compacting the .jar file. On Linux their are command-line commands to do the same.


thanks, I am runing openHAB on Windows too: I just modified the zip file with the Explorer ZIP-handling, and now things work for me too. No clue why it did not work for me before with 7-zip.


I tried to puzzle out when the Aeotec Multisensor 6 (= ZW100) reports data in battery mode (which is different from USB powered mode). Here is my understanding:

The “Wakeup Period -> Wakeup Interval” determines the minimum interval in that the temperature values, humidity values, luminance values, UV values and battery values are reported.

All of these values are reported only at the time when the device also does a wakeup. [exceptions to this may be: “low battery” (parameter 39) and “low temperature” (parameter 46)]

If configuration parameter 40 “Selective Reporting” is enabled, then the data for the sensors is only sent at the wakeup time when the corresponding threshold was reached (as defined in Parameters 41 through 45). When the threshold was not reached, the data is not reported.


  • Wakeup Interval is set to 600 seconds
  • Parameter 40 is enabled
  • Parameter 41 (Temperature) is set to 10 (a change in 1 degree Celsius is reported)
    -> Temperature change is < 1 degree Celsus: no report
    -> Temperature change is >= 1 degree Celsus: temperature report is sent at the end of the current 600 second interval.

If one of configuration parameter 101 through 103 is set (Group n Periodic Reports; bitcoded value which defines which sensor is to be reported periodically), then the reporting inverval is the value of the corresponding configuration parameter 111 through 113, rounded up to a multiple of the Wakeup Interval.
Example a)

  • Wakeup Interval is set to 600 seconds
  • Parameter 101 Temperature is set to 32 (bitcode for temperature)
  • Parameter 111 is set to 300 seconds
    -> Temperature report is sent at a 600 seconds interval

Example b)

  • Wakeup Interval is set to 600 seconds
  • Parameter 101 Temperature is set to 32 (bitcode for temperature)
  • Parameter 111 Temperature is set to 1800 seconds
    -> Temperature report is sent at a 1800 seconds inverval

Thresholds and “Group n Periodic Reports” can be combined.

‘Motion Detection’ reports are reported immediately, independently of the setting of the configuration parameters above.

Reads Complicated? :wink:

Anybody who has a correction to the above?

Keep in mind, this applies only for battery powered devices!


1 Like

I don’t see any corrections above, your explainations of the MS6 parameter settings are correct!

Just to add to #2 example using a different number to clear up decimal representations.

If param 41 (temperature) is set to 18 (a change in 1.8 degree celcius is reported)
-> Temperature change is < 1.8: no report
-> temperature change is >= 1.8: temperature report is sent at the end of the current interval setting.

1 Like

Just a note to those people modifying the database directly in the JAR - it would be appreciated (by all) if you can provide a pull request on github to fix any errors in the database. If the issue isn’t solved at source, then you will have to modify the database each time you upgrade, and others won’t benefit from the solutions you’ve found.

It would also be good to ensure the online database is also updated since this will hopefully become the main source for OH1 in future, and is already the source for the OH2 database…


have you got the tamper switch and UV working since?

I’am also having some trouble with my Multisensor 6. Habmin doesn’t seam to register when the device wakes up. In Habmin the last wakeup time of my device is weeks ago. If I want to set a configuration parameter on the device I always have to push the button short after setting the value, or it will never be set. (I’ve waited multiple days) I’am using the latest binding v. 1.8.1. Will this problem also be fixed?

Edit: I think the problem is that the device doesn’t wake up by interval. The only way to wake up my device is by pressing the button for 3 seconds. (My Multisensor is powered by USB) I’ve enabled the Z-Wave debug log and waited for several hours, but there are no “is alive” messages from the Multisensor. How can I solve this problem?

It sounds like you haven’t configured the wakeup class? If that’s not set, then wakeup won’t be received, and you will need to wake it manually. Just use HABmin to set the wakeup node to the controller (normally node 1).

Do you mean the “Target Node” under “Wakeup Period”? This is already set to 1, which is the Z-Stick:

Also I cannot change this value in Habmin. I can only change the “Association Groups”. The Z-Stick is a member of group 1, but still I’am receiving no wake up commands from the Multisensor. What am I doing wrong?

Sorry - I forgot you can’t change this… If it says 1, then it should be ok, but maybe not (well, clearly not from the sound of it!). To update it, you can change the interval - it’s the same command that gets sent to set the interval and the target node.

I’ve tried to set the wakeup interval to 360. The value was set after I pressed the button on the Multisensor. But the device didn’t wake up after 6 minutes. Ii also did not wakeup after a few days. It only wakes up when I press the button. What could be the problem?

Hello all,

i had a problem with the precision of measurements by humidity and temperature - and was in contact with the engeneers of aeon. So a new version 1.07 is greated but the parameters differ to the “old” version 1.06. I am not the java programmer, but i can explain the changed values:

Param 9 is new “Report the current power mode …” / default = n/a and size is 2
Param 42 “Threshold change humidity…” / default is 10 (%) and size is 1 (2 in version 1.06)
Param 44 “Threshold change battery …” / default is 10(%) and size is 1 (2 in version 1.06)

Here the europe version of the engeneers document for version 1.07:
9 Multisensor 6 V1.07.pdf (300.3 KB)

A version 1.08 is working on with the option to ON/OFF the green flashing led.

Is there a posibility to change the size of the parms in my xml file and restart OH so i can change the params in Habmin? or is there any other solution?

Thanks to all for help.

We would need to generate a new version of the device in the database for the new firmware version, and then copy all the parameters to the new device and edit the changed parameters.

Hi @chris,

i uploaded a xml file of a device with version 1.07. But i will not change the parameters online so i upload the engeneer doc fpr version 1.07 too. If i can support any more let me know.

I have 10 of these sensors running and where happy to get the updateted binding :wink:


Thanks. I will try and create a new device so you can update the parameters. I’m travelling for work this week but will try and do this tonight if I have time.

Sorry for the delay - this week has been a long week of travel…

I’ve now created the new device - currently it’s the same as the existing ZW100, but the version is set, and you can edit this to add the new parameters. If you want to delete a parameter, please mark it as “DELETE ME” or something so it’s obvious you want it deleted and I’ll sort this out when you’ve made the changes…

Hello @chris,

i’ve updated the parameters of the new device. Thank you. At some parameters i have corrected or expandet the description. No Parameters to delete but please take a look at param number 9 - may bee it can not be used.