Apple Homekit Automation and OpenHab Accessories

I have tried to use Homekit Automation to control OpenHab Accessories. I can create Automations and the Automations can control my OpenHab Accesoriess but if I reboot the Openhab server all OpenHab Accessories are often removed from the Homekit Automation setups after the reboot.

I run OpenHab 3.2 and openHabian on a Raspberry PI 4.

Exactly the same behavior in my Installation. Found a Solution?

@snapjack @Erling

in general, the configuration in home app get reseted if openhab provides a list of accessories which is empty or different to previous one. this could have different reasons.

  • i assume you dont change item configuration, only restart openhab, right?
  • do you need to re-pair after the restart, i.e. add openhab as bridge to home app, or your accessories appears in home app correctly but without room assigned to them and without automation?
  • how do you restart openhab exactly?
  • how many homekit items you have approx

as first thing i would try to increase the start delay from 30 to 300 homekit settings

My system has worked perfectly the last three weeks :slight_smile:
In the period i have changed several of my rules and updated to openHab 3.3M1.
I have also discussed the problem under the Topic “Homekit looses rooms” where I have added more info.
I now keep a log of all changes and return if I see the problem again.

Hello, I deleted all my openhab items from Homekit except for two items. These are used to track presence of the two persons of the home using the Homekit/Iphone presence detection and an automation to set the items accordingly. The issue is not to re-pair the openhab bridge, only in the automation the items disappeared and you have to add them again. I tracked the issues during several restarts of openhab now, and the items in the automation do not get lost everytime. So it maybe has something to do with changes within openhab, that slowdown restart (cleaning openhab cache etc.). I increased start delay to 300 and will track what happens next…

Error still persists, No Idea what to try next… :frowning:

@snapjack there was a bug which could lead to issues with the restart. the bug is fixed. please try latest build if possible and let me know if you still have the issue