Apply tags to items added/linked in Paper UI

No one has run into this?

I have, for the items I want to use with the Echo Binding I just manually create in the .items file. It would be nice to be able to add the tags for each thing in PaperUI though.

1 Like

I tried to manually edit the json db file and add in the [“Lighting”] tag to the tags section. It did not appear to impact smarthome:items list. If I update another item in items it also wipes out the tag.

If I got that right, have a look at HABmin Things’ Channels. You can add Homekit tags there. Works fine for me.

Tried that. It worked insofar as the item now shows up as being available. Oddly, though, switching it on and off does nothing. BUT, if I connect another switch to it, and set up a rule to change switch it on and off like that, then it works…

What about adding yet another way of specifying smarthome items, e.g. via groups?
I started working on it and it seems to work pretty well:

yes, thank you @Schnicki, that totally works and keeps me from having to define extra items just for echo compatibility. It seems like this should eventually go into paperUI as well, but this works for now.

Does the item show up AND work for you? For some reason, it’s showing up but its not responsive. I’m trying to control an item in homekit.

yeah, I can have my echo turn on/off and dim lights & fans

I also tried those things. What got me going, was the REST API. So, just send a PUT request to http://:/rest/items//tags/Lighting to set a tag called “Lighting”. I use the “Advacned REST Client” available as a plugin to Chrome to do this, but you can also go to your OpenHAB-server to URL /doc/index.html, and use the built-in REST client. It worked for me, and I now have tags successfully set, and HomeKit working :slight_smile:

1 Like

Ooooo interesting. I didn’t even think I to try the REST API! I’ll try this out on my end. Thanks!

For me the tag field within HABmin is greyed out and I can’t edit it. I created all items via paperui and don’t have a .items file anymore. Any idea what the greyed out tag field could be caused by?


I got the latest snapshot installed

A tag field within paperui would be great :slight_smile:


Using the REST API is brilliant. I’ve been looking all over trying to figure out how to set the tags, but there is NOTHING telling me how to do it via the web interface. It is a complete kludge, but it works perfectly. My device became available Alexa straight away after setting the tag and doing a new discovery on the Echo.

I tried the Habmin thing channel method; it worked for some things, but not for others (the tags get cleared on save).
It also doesn’t work for tagging Group items (since there is no associated Thing). I also can’t edit item configuration in Habmin (everything is read-only / greyed out).

Is the REST API the only known solution to these problems? At least it’s better than what I was doing: shut down openhab2 service; edit JSON DB files; restart openhab2 service.


1 Like

I have been doing the shut down and editing the json file directly as well.

How to add tags to items using Test API?

For google home support I found this thread and originally used the rest api, but just noticed that you can also add tags in the console which is even easier. Wanted to cross post it here as well.

openhab> items
Usage: smarthome:items addTag - adds a tag to the given item
Usage: smarthome:items rmTag - removes a tag from the given item

1 Like

even faster is to use HabMin - it allows tags to be added. Just unlink channel and re-link with tag…

Nice to see that we have some workarounds. But blocking things like this really stop the adoption of the PaperUI, or even leave users in a state where they would like to transition all there items to config files again. Can we not just make sure that we can add tags from the now recommend PaperUI?

I tried this …
Does not matter whether i unlink or not the “tag” field keeps greyed out in HABmin.

Keeps up with REST, even this is pretty confusing to use