Apt-get update throws errow

Running openHabian latest snapshot, did’t change anything.
As I made a apt-get update today, I ran into the follwing problem:

openhabian@openhabianpi:/etc/apt/sources.list.d $ sudo apt-get update
Get:1 http://davesteele.github.io/comitup/repo comitup InRelease [3,936 B]
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:4 https://deb.nodesource.com/node_14.x buster InRelease
Err:1 http://davesteele.github.io/comitup/repo comitup InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0959C4A3DCF89FBF
Get:5 https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable InRelease [12.8 kB]
Get:6 https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable/main armhf Packages [1,851 B]
Fetched 14.6 kB in 2s (7,197 B/s)
Reading package lists... Done

What’s wrong with the davesteele repository and what can I do against it? Thank you !

Solved it by:

sudo wget https://davesteele.github.io/key-366150CE.pub.txt
sudo apt-key add key-366150CE.pub.txt
1 Like