Astro Binding - Sun daylight event missing


since 19.05.2017, my astro binding is not firing the daylight event. This is the last log entry:

2017-05-18 05:10:00.019 [ChannelTriggeredEvent     ] - astro:sun:local:daylight#event triggered START
2017-05-18 20:35:00.024 [ChannelTriggeredEvent     ] - astro:sun:local:daylight#event triggered END

All other events belonging to “astro:sun:local:” are still working without problems.
Is anybody else having this issue or any idea what could cause this?
Many thanks in advance & Best regards,

I guess could be related to the latest issues with the astro binding: Astrobinding throws an NullPointer error

Thanks sihui,

I’am afraid you’re right :frowning:

My longitude is 8.831103 and also i see:

2017-05-21 00:00:00.083 [ERROR] [org.quartz.core.ErrorLogger         ] - Job (astro:sun:local.job-daily-sun threw an exception.

Just updated to Build #922
I’ll add a post to the thread you mentioned. sigh Updating to Build #922 solved one problem and created another.

Odd…karaf says: | Astro Binding

Paper UI:
binding-astro - 2.1.0.SNAPSHOT

for all other 2.1.x bindings, karaf seems to report the same base number. Could this be due to move of the astro binding?

Just to close this issue: Updating to Build #925 solved the issue, events firing again!

2017-05-24 20:43:00.027 [ChannelTriggeredEvent     ] - astro:sun:local:daylight#event triggered END