Astro not updating every day

Hi all,

I’m having a bit of trouble with the astro binding. In general, the binding updates all data such as dawn and dusk almost on the dot of midnight every night. But sometimes, the update doesn’t occur at all and may subsequently fail to update for several days. This obviously affects rules that check if the time is currently between dusk and dawn etc.

As a workaround I was trying to implement a rule at 5 past midnight so that if the times hadn’t been updated the day would just be incremented by 1. I haven’t got that working and it would still be less than ideal because if the dusk and dawn simply increment by a day for a month, they will no longer be representative of actual dusk and dawn.

Does anyone know of a way to ask the astro binding to do a force update?

Any assistance would be greatly appreciated!


You tagged astro1.8… what version of OH and what version of Astro binding are you using?

Sorry, that was a bit of overzealous tagging. I’m using astro 2.2 with OH2 build 1005.

After should update on its own every night. There is no way I know of to force it to update short of updating the .things file where the Astro Things are defined, and I bet you are using PaperUI to define your things.

There have been a number of bug fixes to the Astro binding over the past few weeks. Perhaps this as already been fixed in the latest…

I’m also having Astro issues. I have the rules below:

rule "Sunrise started"
     Channel 'astro:sun:local:rise#event' triggered START 
    logInfo("time-of-day.rules", "Its Sunrise")

rule "Sunset started"
    Channel 'astro:sun:local:set#event' triggered START 
    logInfo("time-of-day.rules", "Its Sunset")

I’m not getting anything in the log and the switch is not updating. I’m getting other rule’s logInfo, but Sunrise/Sunset are no longer working.

I’m on the OH2.1 release.

All I can recommend is to upgrade to the 2.2 snapshot and see if it still has problems. There have been a lot of bugs fixed in Astro since the 2.1 Release.

Upgrade the Astro binding or to OH2.2? Do I do that through the openhab-config menu?

Upgrade to OH 2.2. see the installation instructions for what ever is you are running on. If you are using openHABian, there is an option in one of it’s menus.

1 Like