[Astro]

Hi all,
I’ve added the astrobinding to my openhab.
it’s all configured by the UI. but when I enter a Earliest or Latest time and save. the time is not displayed only --:-- see image

The logviewer gives an error at config and every night when it updates the times.

2020-11-28 15:42:49.761 [WARN ] [ng.astro.internal.util.DateTimeUtils] - Can not parse astro channel configuration ‘1970-01-01T21:00:00.000Z’ to hour and minutes, use pattern hh:mm, ignoring!

I only entered the hours and minuts from the dropdown menu. but its converted to a full date time format.

i am on the OH 2.5.10 Release build, does someone have the same problem and how to fix it?

I just set the system local information for OH and never need to configure the astro channels.

The official documentation mentions tose settings nu I am sire you looked there before posting. The developer writing the documentation is the ultimate expert.

This also was mentioned in this thread: Why does my Astrobinding not follow the offset declared in Paper UI
As far as I understand it is a bug in Paper UI and it seems to be possible to manually fix it in jsondb.

1 Like

Yes it looks like a bug in paper ui.
I had the same with setting sunset end for one hour later.
But then Rosko saidto me to fill in the Range extender and there when ifilled inthe offset , the earliest and the latested , thesame error msg was showing up, if leave the fieldsearliestand latest blanc there was no errormsg and the offset is working fine.

Thanks for all your replies.
i have put everything in the .things file and now it works as intended.
funny detail, the paper ui now shows the times enter in the .things, its only not editable in the paper ui. no big deal if you know it.