Attempting to send a state update of an item which doesn't exist

I see what you mean.
However, my YAML contains at various visible: "=props.door_lock ? true : false" lines. I tried solving this by using visible: "!=props.door_lock ? false : items[props.door_lock].state === null ? false : true" but that doesn’t work… Any hints here?

maybe not null but undefined.Try it

items[props.door_lock].state === undefined ? false : true"

"=items[props.door_lock].state !== 'NULL' ? true : false" did the trick

That’s also the solution in my case.
Played around to check the possibilities how to configure widgets and forgot to add items.
So all the time you update this page where the widgets are placed, you will have this entry in the log file.
BTW:
Maybe useful information for newcomers - reading log files (openhab.log & events.log) through browser, just use port 9001, e.g.:

http://openhabian:9001/

Even though it wasn’t causing any material issues, I finally (after months) got around to debugging the same error occurring in my setup.

The steps I took were:

  • Browsed through various Main UI pages whilst running tail -f /var/log/openhab/openhab.log in a command shell
  • This fairly quickly found the page which was generating the error message… Of course it had to be the Overview Page, with a huge amount on widgets on it :slight_smile:
  • I created a new ‘test’ page, and cut ‘n’ paste the YAML from my overview page (just changing the label at the top of the page to test), and once it was saved, browsed to the page, to ensure I had reproduced the error
  • I then deleted each widget, one by one, on the test page above, and after saving the page, I would refresh the browser, and check the error log. Eventually this led me to the guilty widget, which of course had to be the second to last on the page :slight_smile:
  • From there it was pretty easy to find, when just looking at a singular widget. Hidden away in an icon state (color), it was looking for a props item, which wasn’t being even asked for in the widget configuration section. Just a silly cut ‘n’ paste error…

Any rocket science in the above? No… But sometimes it is easy to bypass (/forget) basic problem solving techniques, and this was a quick, non-destructive way to isolate the problem, after a few prior painful attempts to browse through the Overview pages entire YAML code…

1 Like