Audio Output doesn't work: RPi3 and openHABian


I’m using RPi3 with openHABian.
I’m able to play mp3 files on OS-System console (mpg321).

I’ve configured:
the Audio in the Paper UI: “System Speaker (with mp3 support)”.

I’ve checked on the karaf console:

openhab> smarthome:audio sinks


openhab> smarthome:voice voices
marytts:bits3hsmm bits3-hsmm - German
marytts:bits1hsmm bits1-hsmm - German
marytts:cmuslthsmm cmu-slt-hsmm - English (United States)

Here comes the problem:
If I try to play an mp3 file on the karaf-console:

openhab> smarthome:audio play doorbell.mp3

This results to the log:

2017-05-09 08:14:11.159 [ERROR] [.internal.EnhancedJavaSoundAudioSink] - An exception occurred while playing audio : 'Cannot create AudioDevice'

If I try to TTS on the karaf-console:

openhab> smarthome:voice say Hello world!

This results to the log:

2017-05-09 08:12:00.762 [WARN ] [] - No line found: No line matching interface SourceDataLine supporting format PCM_SIGNED 16000.0 Hz, 16 bit, mono, 2 bytes/frame, 8000.0 frames/second, little-endian is supported.
2017-05-09 08:12:00.764 [INFO ] [] - Available lines are:

… it seems that no line is available

I restarted the sytem multiple times, tried stable and unstable build of openhab.

so I’m helpless :frowning: and looking for any support :slight_smile:

Same here :frowning:

A relief - I’m not the only one…
I recently tried to configure “Web Audio” as audio sink in Paper UI.
It worked with that.
I wonder that only we two have that problem?

Just I have updated to the last unstable build - it’s working now. :slight_smile:

Im on the latest unstable build and it does not work for me. Same errors as mentioned above.
For voice and audio I get:

2017-05-24 20:37:49.240 [ERROR] [.internal.EnhancedJavaSoundAudioSink] - An exception occurred while playing audio : 'Cannot create AudioDevice'

and no sound!

Commands from the cli like

aplay test.wav

are working fine though.

Sorry: after

sudo adduser openhab audio
sudo reboot

it also works for me

i tried it with docker but no luck…has anyone getting sound to work on rpi4 with docker?