Authentication issue since past week in Somfy binding

I was using Somfy binding for past few months without an issue to control shutters. SInce past week it is not longer working. I see in OpenHab that there is an error in bridge with “Authentication challenge”.

I have tried to reset password and found a strange thing. I can log into Tahoma using Android app and but if I am trying to log in through TaHoma® I am always getting an error that password is incorrect.

Do you know about any changes in Somfy authentication or it is some intermittent issue on their side.

1 Like

I am having the same issue since last Tuesday. I have an somfy Connexxoon. I contacted Somfy support, but they were not very helpful. They just stated that the Connexxoon can only be controlled via the Connexxoon phone app. I can login in the connexxoon app and the somfy connect website. The tahoma website doesn’t work for me either. I can log in, but then shows me ‘An error has occured on the server’. When I purposely use a wrong password it shows me the wrong password error. So I don’t know what that first error message means.

I tried a new install in docker, to check if its something in my configuration. But didn’t work. Then I installed Home Assistant on my Synology Docker. I think they use a different method of authentication, since I didn’t need to enter a password, but got a prompt from the Somfy website to allow access. Then it worked.

I was also calling support. I was not able to get to the guy that had permissions to restart some servers but day after it started to work. I guess there had to be something on Somfy side.
Eh… I wishi for local integration with Somfy. i would never bought that if I knew.

I have a similiar issue and are not able to connect via the bridge:

I did not change anything but since this morning it is not working anymore.
Then I installed an update for the connexxon using the app. Was forced to it as the app was not working without the update.
But the bridge is still offline. Anyone has similar issues or a solution for that? Very annoying as all rollershuttur control in my house is based on this bridge…

I had a similar issue a few months back because I think they changed something but did end up managing to fix it, however overnight I started getting the same authentication issue and my testing from last time is all failing this time.
I am willing to bet that they have changed things on their side again and Somfy support leaves much to be desired.

I believe the difference with HomeAssistant is that the ‘Somfy’ integration uses their newer APIs (Somfy Open API Developer Portal | APIs & Docs) which would be a complete rewrite of the OH binding.
You might have the same issue with their ‘Tahoma’ integration which I think looks like it might use the same method as OH currently does.

I might have a play with the API and be able to set up some rules to trigger actions but not sure I’m any help with the binding itself.

That’s really annoying.

With HomeAssistant everything is still working?

Anyone experience with Velux Binding & KLF200, is it possible to control somfy rollershutters with that? Seems to be a non-cloud based solution?!

the website has an error:
binding uses to login.
guess we have to wait till Somfy fixed it.

this night I disabled the Binding and enabled it again in the morning. The break seems to help, it is working again. Probably that break helps the somfy side to reset…

I disabled for 30-45 minutes and it seemed to do the trick, good spot (may need to wait longer if that doesn’t work for people).
I think I had seen a mention before (probably in your link agove) somewhere about the authentication hitting a rate limit and just giving the bad credentials error still, rather than anything more useful.
I am not sure I ever saw that issue myself, it didn’t solve my issues last time but glad it did this time.

I’ve never been able to sign in to before, even though the binding worked fine (also I had to set the portal URL in OH to be without the www).
According to Somfy support that is only for people in the US and not for people with just a Connexoon.
But there seems to be so many disparate systems and differences between the regions.

I would love to get a local control option though, I have a few too many internet dependant bindings for my liking but not sure how to do that with Somfy.

Disable for some time and enable it fixes the problem fir me too.
I’m in Austria and have a Connexoon.

Same issue here, and this is what I found out:
The reason for the authentication issue is that the user account is blocked.
If have asked for a log file on WHY this happens but haven’t received one.
I assume the amount of calls to the api was restricted and the default setting in the binding is 30 seconds.
Which calculates as 2880 times a day. Has anyone played with this setting in order to achieve a working binding?