Automower Husqvarna

Hi everyone,

i would again need some hints out of the community.
Currently im am struggeling with the Automower binding.

I did the registration of the application + link of API and automower connect as described in the documentation. Added the Application Key + Email/PW in the binding to create the bridge but always facing:

grant type password to URL https://api.authentication.husqvarnagroup.dev/v1/oauth2/token failed with error code unauthorized_client, description Unauthorized client: grant_type is invalid

If i try manually with curl as posted in some other topics i can successfully get the mower ID. Currently i have no clue what is wrong.

Maybe someone can give me a hint. Thank you!

Issue is known:

1 Like

Thank you for your quick response.

Adopted the login api change, please check automower jar, code changes - PR.

Hi.
I try the new version of the bindings but I still have the same interface with Username and Password.
I already made a clear-cache and restart but still.

Here is the configuration windows I have :

Thanks in advance for your help.

Hey!

Please first uninstall the “official” automower binding (from settings|binding) and then copy the provided jar above to addons folder.

Also, just in case, remove existing automower connect bridge and enter your app key&secret (you should see something as below):

At the end, please make sure to update bridge within your automowers (parent pbridge) so they use the newly added bridge.

That should do it. Please let me know how it goes.

Looks like I had download an old JAR. Don’t know.
Anyway all is ok now.
Many thanks for your help.