AVM Fritzbox resets Comet Dect SetPoint

Hello everyone,

my configuration:

  • Raspberry with openHAB 2, AVM Fritz! Binding from Robert Bausdorf
  • Fritzbox 7390, Firmware 6.83
  • Comet DECT Heating device connected to Fritzbox

Problem: when I set a new temperature with SetPoint to the Comet heating, it works, but within a few seconds the Fritzbox resets the value. Please have a look to my logfile, first change is initiated with the openHab, seconds is done automatically by the Fritzbox

HeizungArbeitszimmer_SetpointTemperature changed from 6.0 to 25
'avmfritz:fritzbox:192_168_1_1' changed from ONLINE: FRITZ!Box online to ONLINE: Resuming FRITZ!Box connection with SID 3ae20090f758a53c
HeizungArbeitszimmer_SetpointTemperature changed from 25 to 6.0
'avmfritz:fritzbox:192_168_1_1' changed from ONLINE: Resuming FRITZ!Box connection with SID 3ae20090f758a53c to ONLINE: FRITZ!Box online


Hi Frank,

which configuration do you use for your Comet DECT in the FRITZ! OS? Do you set up a schedule? Vacation mode? Turned off? Do you use groups with a master device?

Hi Christoph,

vacation mode is disabled, no “Heating of” (Heizung aus) period is defined, maybe the Fritz scheduling is active, there is no option to turn it off, I’ve seen no option like “manual mode”- I added a screenshot of the schedule section


Which dates do you configure for “Heating off” (Heizung aus)?

Hi Christoph,

i defined from 01.05 until 01.09, but if delete this section it is excactly the same behavior.


Okay. That’s the reason why the SetTemp is set back to 6.0 (off).

The FRITZ!Box is the leading system and overrules the OH2 binding. You configured the Comet DECT to remain off from first of may until first of september. In this period you cannot set the temperature using the OH2 binding. If you need to do control the Comet DECT using the binding you could try to define a schedule always using EcoTemp (Spartemperatur) set to “off” (aus). I can observer the same behavior in my environment.

Hi Christoph,
i 'm also dealing with this problem but using node red for the rules changing values. Did i maybe miss the solution or is it still an issue ?

BR Stefan

Hi Stefan,

I will do some tests.

Hey Stefan,

Can you give me an example of your item configuration? Did you configure those manually or did you use Paper UI? Thanks.

Hi Christoph,

I’m quite not sure if that’s what you asking for. This is a screenshot showing the active channels of the comet dect defined via paper UI.
Down below there is the rule from node red where i tried quite simple to inject manually two different setpoint to the comet.


BR Stefan

Hi Christoph,

sorry for that. I found the fault. I had to use grafik
instead of grafik

in the grafik

output module.

Also feels like a trap to me
Sending a setpoint like 20.4°C Fritz is rounding to 20.0 °C
Sending a setpoint like 20.6°C Fritz is rounding to 20.5 °C
Looks like Fritz only accepts step’s in half degrees.

Thanks for helping

BR Stefan

Sounds cool. To be honest, I am absolutely not familiar with Node Red. But I am glad you solved your issue on your own.

You are right. The FRITZ!Box only accepts temperatures in 0.5°C steps starting at 8.0°C up to 28.0°C.

So ist there still no soloution for this Problem?

Hi Robin,

What do you mean exactly?

Hi Robin,

I’ve had the same issue. After deleting cache and tmp, setting the temp works flawlessly again and without resetting the Comet.



i deleted chache an temp but the issue ist still there.

My System: Pi3, openHAB 2.2.0 Release Build, Binding 2.2.0.

EcoTemp (Spartemperatur) set to “off” (aus)
Comfort is on

The log:

2018-01-22 17:26:10.234 [ome.event.ItemCommandEvent] - Item 'avmfritz_Comet_DECT_192_168_178_1_119600716704_set_temp' received command 20

2018-01-22 17:26:10.249 [vent.ItemStateChangedEvent] - avmfritz_Comet_DECT_192_168_178_1_119600716704_set_temp changed from 18.5 to 20

2018-01-22 17:26:11.487 [hingStatusInfoChangedEvent] - 'avmfritz:fritzbox:192_168_178_1' changed from ONLINE: FRITZ!Box online to ONLINE: Resuming FRITZ!Box connection with SID 9564f362ef455caf

2018-01-22 17:26:22.980 [vent.ItemStateChangedEvent] - avmfritz_Comet_DECT_192_168_178_1_119600716704_set_temp changed from 20 to 18.5

2018-01-22 17:26:22.989 [hingStatusInfoChangedEvent] - 'avmfritz:fritzbox:192_168_178_1' changed from ONLINE: Resuming FRITZ!Box connection with SID 9564f362ef455caf to ONLINE: FRITZ!Box online

What should i do?

When i set the Temperature via Button like its configured in the Fritz box ist works. But the Thermostat sets the temp ONLY when i manually wake up the Thermostat.:open_mouth:

Hi Peter,

Maybe that is the root problem. After changing the settings in the FRITZ!OS you always receive a message that the data transfer to the device lasts up to 15min. Maybe the AVM API itself has a bug setting a new temperature if the device is in sleep mode. Should we hand over this case to their support and ask for help?

Hi Christoph,

Is it possible that there is a same difference between “item update” and "item command"
controlling via Openhab as controlling via Node Red ? The effect itself sounds quite similar to me.

BR Stefan

Hi Stefan,

There is a difference between postUpdate and sendCommand. The first one updates the state of an item. The latter one updates the state AND sends a command to linked channels. See here for a more detailed description https://docs.openhab.org/configuration/rules-dsl.html#manipulating-item-states.