Backup loop when updating docker image from 2.4.0 to 2.5.0

When updating from 2.4.0 to 2.5.0, it constantly creates backups and the log says that I am already on version 2.4 although the image is on 2.5.0.

I also did a fresh 2.4.0 install and restored my old 2.4.0 instance via the backup tool. The problem persists. :frowning:

What’s wrong?

Welcome to the community!

Take a look at this topic and see if it helps.

1 Like

Well no :smiley: That one will not help. I hope it’s still pleasant to read tho :wink:

But there is a similar topic to yours.


He deleted his openhab userdata folder.

1 Like

Thanks for your responses and hello to the community:) I did a fresh install of 2.4, then used to the backup tool restore the backup of the “corrupted” instance and tried an upgrade to 2.5. Same problem.

So without restoring the backup, I can try again from the start. But to keep things and everything, which files are essential? I am using z-wave and zigbee and some add-ons.

Hey, i have the same problem. I use the tag 2.5.0-armhf-debian from DockerHub.

Even on a fresh install without restoring anything, I still get “You are already on Openhab 2.4.0.”

How does the script find out? I really would like to solve it. Openhab Updating via Docker is unusable at the moment :frowning: