Bali (Somfy) ZWave Remote for blinds shows as unknown Zwave Device


I recently bought some Bali ZWave roller blinds which are working very well with my OH system. The remote that these came with is branded Bali as well, but on the back is shows as Somfy. I’ve included it into my ZWave network with OH3, but it shows as an unknown device and has no channels. Does anyone know how to get this device properly recognized?

For reference, I am referring to the “Plus Remote” here:

It will have to be added to the Zwave database. I think I found the standard version, but do not see the Plus. The instructions are in the Userguide


1 Like

So, I’m trying to use the guide to add this remote, but I don’t have an XML for this node in $userdata/zwave

The item is node35:

/var/lib/openhab/zwave $ ls
network_ff9ea1e8__node_10.xml  network_ff9ea1e8__node_16.xml  network_ff9ea1e8__node_22.xml  network_ff9ea1e8__node_30.xml  network_ff9ea1e8__node_4.xml
network_ff9ea1e8__node_11.xml  network_ff9ea1e8__node_17.xml  network_ff9ea1e8__node_23.xml  network_ff9ea1e8__node_31.xml  network_ff9ea1e8__node_6.xml
network_ff9ea1e8__node_12.xml  network_ff9ea1e8__node_19.xml  network_ff9ea1e8__node_24.xml  network_ff9ea1e8__node_32.xml  network_ff9ea1e8__node_9.xml
network_ff9ea1e8__node_13.xml  network_ff9ea1e8__node_1.xml   network_ff9ea1e8__node_25.xml  network_ff9ea1e8__node_33.xml
network_ff9ea1e8__node_14.xml  network_ff9ea1e8__node_20.xml  network_ff9ea1e8__node_28.xml  network_ff9ea1e8__node_34.xml
network_ff9ea1e8__node_15.xml  network_ff9ea1e8__node_21.xml  network_ff9ea1e8__node_2.xml   network_ff9ea1e8__node_3.xml

@apella12 - is there something I need to do to get an XML file for this node to upload?

It should be there. The only thing that looks a little odd is that UID of the device is not the same as the others. Was this “paired” via the UI–>Zwave–> Scan?.



Yeah, I did include it into my Z-Wave system (per the user manual) by taping the button on the remote and scanning with OH via:

OH Main UI → Things → + → Z-Wave Binding → Scan.

To see if there was some kind of issue with the first time I added this remote, I excluded it and reincluded it into the Z-Wave system. So it moved from node 35 to node 36, but I have the same issue, it shows in the UI, but there is no .xml generated in the file system for my to use to add this device to the ZWave data base:

openhabian@opi:~ $ cd $OPENHAB_USERDATA/zwave
openhabian@opi:/var/lib/openhab/zwave $ ls -al
total 460
drwxrwsr-x  2 openhab openhab  4096 Mar 19 15:04 .
drwxrwsr-x 19 openhab openhab  4096 Jan 31 18:51 ..
-rw-rw-r--  1 openhab openhab 15043 Mar 22 02:50 network_ff9ea1e8__node_10.xml
-rw-rw-r--  1 openhab openhab 15332 Mar 22 02:36 network_ff9ea1e8__node_11.xml
-rw-rw-r--  1 openhab openhab 16682 Mar 22 02:36 network_ff9ea1e8__node_12.xml
-rw-rw-r--  1 openhab openhab 15357 Mar 22 02:50 network_ff9ea1e8__node_13.xml
-rw-rw-r--  1 openhab openhab 15596 Mar 22 02:31 network_ff9ea1e8__node_14.xml
-rw-rw-r--  1 openhab openhab 10271 Mar 22 02:50 network_ff9ea1e8__node_15.xml
-rw-rw-r--  1 openhab openhab 13436 Mar 22 03:42 network_ff9ea1e8__node_16.xml
-rw-rw-r--  1 openhab openhab 18239 Mar 22 02:50 network_ff9ea1e8__node_17.xml
-rw-rw-r--  1 openhab openhab 26481 Mar 22 02:50 network_ff9ea1e8__node_19.xml
-rw-rw-r--  1 openhab openhab  2154 Mar 22 04:23 network_ff9ea1e8__node_1.xml
-rw-rw-r--  1 openhab openhab  9906 Mar 22 04:29 network_ff9ea1e8__node_20.xml
-rw-rw-r--  1 openhab openhab 10194 Mar 22 05:55 network_ff9ea1e8__node_21.xml
-rw-r--r--  1 openhab openhab 24162 Mar 22 02:25 network_ff9ea1e8__node_22.xml
-rw-rw-r--  1 openhab openhab 26540 Mar 22 02:50 network_ff9ea1e8__node_23.xml
-rw-r--r--  1 openhab openhab  2069 Mar 21 02:43 network_ff9ea1e8__node_24.xml
-rw-rw-r--  1 openhab openhab 10157 Mar 22 02:28 network_ff9ea1e8__node_25.xml
-rw-r--r--  1 openhab openhab 33536 Mar 22 04:29 network_ff9ea1e8__node_28.xml
-rw-rw-r--  1 openhab openhab 14280 Mar 22 03:58 network_ff9ea1e8__node_2.xml
-rw-r--r--  1 openhab openhab 29614 Mar 22 02:28 network_ff9ea1e8__node_30.xml
-rw-r--r--  1 openhab openhab  8081 Mar 22 02:50 network_ff9ea1e8__node_31.xml
-rw-r--r--  1 openhab openhab  8134 Mar 22 02:28 network_ff9ea1e8__node_32.xml
-rw-r--r--  1 openhab openhab  8168 Mar 22 02:40 network_ff9ea1e8__node_33.xml
-rw-r--r--  1 openhab openhab  8116 Mar 22 02:50 network_ff9ea1e8__node_34.xml
-rw-rw-r--  1 openhab openhab 15141 Mar 22 03:38 network_ff9ea1e8__node_3.xml
-rw-rw-r--  1 openhab openhab 14898 Mar 22 05:16 network_ff9ea1e8__node_4.xml
-rw-rw-r--  1 openhab openhab 15816 Mar 22 02:50 network_ff9ea1e8__node_6.xml
-rw-rw-r--  1 openhab openhab 28813 Mar 22 04:02 network_ff9ea1e8__node_9.xml

Is there some feature I need to turn on to get devices that have no database entries to give .xmls?

Any thing else I should try to debug why I’m not getting an xml?

How long did you wait? I hit this problem before (with a different new Zwave device) and it was because I wasn’t patient enough. I don’t know how long you have to wait, but the .xml is not written instantly. I checked in the morning after not seeing it the prior evening and it was there. I can’t tell you if you need to wait minutes or hours, but I can say that it is definitely not instant to write out to the file system.

1 Like

I would look closely at the Standard version in the database compared to your Plus manual and do one of two things. 1) If there is no discernable difference just modify that one to include 4252:5A31. 2) If there are differences, use the icon to download the OH2 XML. Change the device name to include “plus”, change the numbers to be just 4252:5A31 (and any obvious small changes). Then use that XML for the basis of your new device. After that is loaded, make the changes in parameters and endpoints, etc. to align with your “plus” device.

I have never done this, but I think it should work.


1 Like

Thanks for the feedback. The first time I waited several days. Then I excluded it and re-included it and several hours later I still have no xml.