Basic openhabian issues (even within openhabian-config)

Dear all,

since we have moved ~ half a year ago and upgrading to OH 3 in a clean way was anyhow on my todo list, I started doing so with a fresh setup: I use a RP 4 with 8 GB RAM with a 128 GB SD card as setup.

Installation was done via openHABian v1.7.1 32 bit version. I like file based config and did as much as possible this way. I use a Ubiquiti network just for information as this is also quite powerful and has potential impact on network related topics.

Currently I run into several somehow basic issues and hence believe something basic is wrong. I already read a lot within the forum but I think it is time to ask for dedicated support / hints. I also have done a very fresh openhabian setup as well which same / similar behavior.

  1. openhabian-config not fully working (e.g. Update / Using ZRAM as well as Fix Permissions) give an error “There was an error or interruption during the execution of…”

  2. Changing branches just quickly shows a hint, nothing changes: 2022-01-24_19:47:52_CET [openHABian] Updating myself… mv: cannot stat ‘/opt/openhabian/docs/’: No such file or directory

  3. Homeatic IP binding just get’s values randomly / after openhab reboot but no update. Raspberrymatic on RPi4 is detected as CCU2 which does not feel correct.

  4. Mosquitto issue as described and posted

I hope somebody can give me a hint.

Thanks a lot for the great for on Openhab, especially 3.2 - looking forward to have it hopefully running soon again ;-).


Without any more info about 1. and 2., it’s hard to tell what exactly might going on
So please provide some debug information

Definitely! I had to learn this first :wink:

I even did a fresh installation again and ran into issues even when not chaning anything! Also openhab was not working at that time. I then run the updates via apt-get manually, started openhabian-config several times, rebooted etc., hence got openhabian working. Feels like some basics are currently not working, maybe some conflict with some package?

openHABian-install-successful in /opt/ exists exists. I then tried to perform similar actions and putting the log here. Still not sure if this is correct as the log is really long! Please give feedback for newbe if this is somehow wrong. Can I find a log file somewhere instead of copying the text manually? Log is attached.
log.log (256.0 KB)

  • Enabling openhabian log and rebooting the system, then starten openhabian-config at timestamp 2022-01-25_19:49:46

  • Log Output after “14 fix permissions” at 2022-01-25_19:53:49

  • Log Output after “38 Use Z-Ram” with error prompt " There was an error or interruption during the execution of:" at 2022-01-25_19:56:28

  • Log output after “Update Z-Ram” at 2022-01-25_19:58:17

  • Again “Use Z-Ram” as “Update z-Ram” has not shown any error in the openhabian “gui” at 2022-01-25_19:59:30


Well, fix permissions doesn’t seem to throw an error, so that should work.
But what you can see is that for some reason there are problems when stopping the ZRAM service, but I can’t tell why:

+ echo -n '2022-01-25_19:56:51_CET [openHABian] Updating zram service... '
2022-01-25_19:56:51_CET [openHABian] Updating zram service... + cond_redirect zram-config stop
+ [[ -n '' ]]
+ echo -e '\n\033[90;01m$ zram-config stop \033[39;49;00m'

$ zram-config stop
+ zram-config stop
Failed to kill zram-config.service. Exiting!
+ return 1
+ echo 'FAILED (stop zram)'
FAILED (stop zram)
+ return 1

there should be a log for the zram service itself, maybe it has some hints why it is failing. (/var/log should be the directory if I remember correctly)

I saw toda an update of openhabian on github: Release openHABian v1.7.2 · openhab/openhabian · GitHub

Any guess if my issues are related to this as I had even issues with a “vanilla” (unchanged) openhabian setup?

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.