Basic Setup: Cannot determine item type in sitemap defined in items file

Hi All,

I’m starting using OH1.8 on a raZpberry ultimately to combine Zwave and Hue lights. Starting from the demo house, I’ve removed/uncommented most of the things and declared some items in my default.items file which looks like this:

Group All
Group gFF “First Floor: Living Room & Kitchen” (All)
Group gGF “Ground Floor: Sleeping Room & Bath” (All)
Group gEF “Entrance Floor” (All)
Group Weather (All)
Group Status (All)
Group Hue (All)

/* active groups */
Group:Number:AVG Heating “Avg. Heater Temperature [%.1f °C]” (All)
Group:Number:AVG Temperature “Avg. Room Temperature [%.1f °C]” (Status)

/* Locations */
Location myLocation “Our home in Munich” (All)


  • Switch for inner door that activate heating in general,
  • i.e. no heating if inner door is open
    Switch doorInside “Inside Door” (gEF)

The last switch is the main object of interest for this topic and I’ve included into default.sitemap file like this:

sitemap schopenHome label=“SchopenHome”
Frame label=“Groups” {
Group item=gEF icon="garden"
Group item=gFF label=“Living Room & Kitchen” icon="firstfloor"
Group item=gGF label=“Sleeping Room & Bath” icon=“groundfloor”

Frame label="Grouped Devices" icon="hue" {
		Switch item=doorInside mappings=[0="Open", 1="Closed"] // icon="shield-2"
		Setpoint item=TemperatureSetpoint minValue=16 maxValue=28 step=0.5
		Group item=Heating
		Colorpicker item=LightRGB icon="slider"
		Group item=Hue


When restarting openhab, this is the log I get:

2016-01-24 16:27:54.102 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-01-24 16:28:02.050 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.sitemap’
2016-01-24 16:28:03.762 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.script’
2016-01-24 16:28:04.106 [INFO ] [] - Started REST API at /rest
2016-01-24 16:28:04.310 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'logging.persist’
2016-01-24 16:28:04.404 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'exec.persist’
2016-01-24 16:28:04.428 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'rrd4j.persist’
2016-01-24 16:28:04.449 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'db4o.persist’
2016-01-24 16:28:04.505 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.items’
2016-01-24 16:28:09.574 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/
2016-01-24 16:28:14.548 [INFO ] [.p.rrd4j.internal.RRD4jService] - Removing invalid defintion component = null heartbeat = 0 min/max = 0.0/0.0 step = 0 0 archives(s) = [] 0 items(s) = []
2016-01-24 16:28:14.831 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.rules’
2016-01-24 16:28:21.174 [INFO ] [g.openhab.model.script.Weather] - Temperature evolved of 0 degrees.
2016-01-24 16:28:21.302 [INFO ] [.service.AbstractActiveService] - NTP Refresh Service has been started
2016-01-24 16:28:21.384 [INFO ] [.service.AbstractActiveService] - HTTP Refresh Service has been started
2016-01-24 16:28:21.701 [INFO ] [.z.internal.ZWaveActiveBinding] - ZWave ‘updated’ with null config
2016-01-24 16:28:26.454 [INFO ] [o.o.b.w.i.common.WeatherConfig] - LocationConfig[providerName=YAHOO,language=en,updateInterval=30,latitude=48.17927,longitude=11.56822,locationId=myLocation,name=schopenHome]
2016-01-24 16:28:29.461 [INFO ] [.o.b.w.i.s.WeatherJobScheduler] - Disabling weather locationId ‘myLocation’, no binding available
2016-01-24 16:28:44.049 [WARN ] [.o.u.w.i.render.SwitchRenderer] - Cannot determine item type of 'doorInside’
org.openhab.core.items.ItemNotFoundException: Item ‘doorInside’ could not be found in the item registry
at org.openhab.core.internal.items.ItemRegistryImpl.getItem( ~[na:na]

There are bunch of errors here, bit I’m trying to narrow it down and ultimately, I have the feeling that It’s still not clear to me how I can register items and use them in sitemaps. Also I’m asking myself: “Why do I have to declare item types in sitemaps since I have them defined in the *.items file already?”

Does anybody have insights why it is throwing “Cannot determine item type of ‘doorInside’” ? I have similar errors with ColorPicker etc., so assuming a general misunderstanding. Thx.

I don’t see anything apparently wrong but since you are starting with a complicated example demo config, what would recommend is starting from scratch with brand new .items, .rules, and .sitemap files and build it up little by little. It is entirely possible that there is a syntax error somewhere or something like that which might be tripping you up. When I was learning I kept the demo around for reference but started my config from scratch and it worked quite well.

Hi & ok. Though that’s not quite the reply I was hoping to get, I’ll start from scratch with empty files. Anyways, good to know that in theory I’ve been correct, so thx for that.