Basic UI - Live Update

Tags: #<Tag:0x00007f1e5f9ac5e8> #<Tag:0x00007f1e5f9ac4a8>
(HomeAutomation) #21

I see this problem if I update the sitemap from VSC. Then I need to refresh the browser to get live update back.


(Josh Patterson) #22

I have noticed this too, anytime you “break” the sitemap or items files, auto update stops working until you have fixed the file AND restarted openhab. I think this might out to make it 100% reproducible… I reproduced it 3 times w/o fail. Took my working items file, (It had been working w/o fail for ~24 hours) and added a new line to the end with a syntactically incorrect word, generateerror. Then refresh the browser, everything is"broken"; then fix the error and reload. Everything shows up, but auto refresh no longer works, I have to hit F5/reload to see current values. Once I restart openhab2 everything is back to working fine. I’m guessing there is some code to prevent bombarding the server when the file is in error that isn’t getting cleared correctly once a non error generating file is in place again. Anyway hope maybe that helps someone figure it out! (Just created an account to say all this!)



(Danny mullen) #23

@jlpatte2 I can reproduce this way also. Wonder if you need to file an issue for this on the git page. Have you done that before? I could walk you through if needed.


(Stefan) #24

@jlpatte2 Thanks for reporting this here!

I am experiencing this issue quite often (using Firefox and different configurations) but never had time to track it down. Yes it happens more often when I modify configuration.

Yeah we should report that on Github. I can help too when needed.

Are there some logs / indicators (except a clock on every sitemap page ;)) where I can see that update doesn’t work?


(Kjetil Asdal) #25

My observation on this is that a sitemap that contains a Text element connected to a String item will not automatically refresh.

It’s been a while since I tried to look into this, but I am pretty sure I observed that by simply adding or removing such an element, my sitemap was automatically refreshed - and not.

Anyone else seen this?


(Stefan) #26

What I observe is a complete “not updating”, not only text elements but also Buttons, Sliders, … don’t get updated anymore. The only ways to get them to update is:

  • hitting refresh
  • clicking to a different sitemap page
  • restarting the server

(Mathias Ewald) #27

I have the same problems. No idea how to troubleshoot. If anyone wants to screen share with me and investigate: be my guest.


(Lionello Marrelli) #28

I am experiencing the same behavior. I am on a Raspberry pi v3, OpenHAB v2.4 upgraded from OpenHAB v2.3 installed through apt-get on a freshly installed raspbian Stretch. I use the Chrome web browser on a windows 10 machine.
I am currently re-building my sitemap from scratch.

I have a simplified test.sitemap that now reproducibly never updates, even after restarting openhab.
I tried to open simultaneously the same page on microsoft Edge browser and on Chrome. I observed that, while on Chrome it does not update, in microsoft Edge it does. I even tried to clear cache and navigation history in Chrome but nothing.
I’ll continue adding elements to the sitemap and see when I’ll broke also edge (then I’ll try with Firefox and Opera too…)
Hope that this may be useful to others

Lionello Marrelli


Should BasicUI be auto-updating?
(Jack Sand) #29

Yes edge is working great, but crome does not (updating)


(Yuriy) #31

NOT UPDATING BECOUSE .sitemap File has a MISTAKES!!! It’s NOT BROWSER or anything else!!! JUST Correct file !!