Basic UI - Live Update

basicui
liveupdate
Tags: #<Tag:0x00007f01431c00e8> #<Tag:0x00007f01431c7fa0>

(Soloam) #1

Hello all, on the Basic UI OpenHab manual Page we can read:

  • Responsive layout suitable for various screen sizes
  • AJAX navigation
  • Live update

I don’t know if I’m doing something wrong, but my Basic UI is not Live Updating. I change my states from MQTT, no changes, if I refresh the page, the page updates.

Thank You


(Josar) #2

Which browser do you use.

I expirience the same with Firefox and crome, edges works often but not always.
Its said after changing items files Openhab has to be restarted.

When i use the android app i see updated states.


(Soloam) #3

Both Firefox and Chrome, yes the android app works. I keep using the classic because of this. Too bad, because the layout of the Basic is a lot better


(Moxified) #4

To chime in. I have seen similar behavior. Sometimes it will update, other times it will not. I use chrome primarily and on a mac. I also get “Offline: waiting for connection to become available” often.


(Rich Koshak) #5

@Josar, @Moxified, do you know if an issue has been filed yet?


(Josar) #6

Some time ago. But seems to be my fault.

And a second try.

But it somehow got to complicated.

Last thing was:

Some users are complaining that refresh is not working after an update of config files.

Now i live with it.


(lipp_markus) #7

Seems to be a persistent problem and I learned to live with it as a manual refresh seems to always update BasicUI.

In case this helps connecting things, I reported it over a year ago after I had this issue for already quite some time Should BasicUI be auto-updating?
According to feedback on that post, this https://github.com/eclipse/smarthome/pull/2030 was supposed to fix it, but no luck.


(Lolodomo) #8

The problem is I think that no contributor was able to reproduce the problem. it is working like a charm for me for example.

Is your OH server behind a reverse proxy ? Apparently it is a case where the update mechanism can fail.


(Soloam) #9

Actually I was planing on configuring the reverse proxy, but still didn’t do it. For me it never works first the Basic UI, I given up on using it! Classic UI works like a charm… No problems


(lipp_markus) #10

I understand and I was not complaining. It happens frequently but not all the time in my case. If I had more info, I’d gladly share it. I have a pretty simple system: no proxy, no openhab, nothing fancy is configured on my system; all is updated; and I had this effect through all snapshots for the last 2-3 years, on raspi as well as an ubuntu VM on a NUC; browser is Chrome on MAC (also always latest update).


(Lolodomo) #11

Playing with my dev env in Eclipse yesterday, and updating my sitemap while the server was running, I finally noticed one time that live update was broken in Firefox and a server restart was required. Only live update through SSE is impacted.
I will try to reproduce again and analyze.


(Moxified) #12

It is intermittent for me which is why I never really chased it. I tried yesterday morning to reproduce it and it worked flawlessly for several hours.

Let us know if you need any help with testing specific things. I would be happy to help any way I can.


(Kevin Hawkins) #13

Mostly doesn’t work for me … so I avoid it.


(CarlJ) #14

It works intermittently for me as well. Especially when I do a lot of changes in the config files.
Closing and reopening browser or app doesn’t work. I really need to restart openHAB and then it’s always solved.
IMO it’s indeed annoying because stability is always my prime concern.


(Soloam) #15

I have more misses than hits, so I given up using it! The classic ui and the Android app work 100%


(Danilo Dello Buono) #16

Hi all!.. I had the same issue on both Firefox and Chrome. I am using Visual Studio to edit my configuration files, and noticed that syntax highlighting was not properly functioning too. I had some items with their name not starting with capital letter. I tried changing this and Visual Studio syntax highlighting started functioning properly. Files were correct even before, and things were working well, apart live update on browsers. But after I changed item names and correct formatting of code (at least according to Visual Studio rules) live update in browsers began to work.

Every time that i change something in items and don’t use “correct formatting” live update stops working. It can be even a space or a tab character, that even if does not mean an error in item or sitemap definition code, it make live update in browser stop working.

Hope this can help someone, dig this out.


(Moxified) #17

Interesting observation. I know I have some lowercase items. I started noticing them when I switched to VS code.

Unless I’m mistaken, this is still a bug that needs to be fixed as I just read through the items doc and uppercase is “recommended”. It says nothing about required. So either we need to change that to required or fix BasicUI if your theory is correct.

That being said, even with my lowercase items as they are, BasicUI auto updates most of the time.


(Danilo Dello Buono) #18

In my case it’s not only about lowercase. As I mentioned, even a space or a tab, can make my sitemap stop dinamically updating in browser.


(Matthew) #19

Hmm - I appear to be having this issue still. There appear to be no live updates received via the basic UI! Did anyone ever find out what the cause of this issue was?


(lipp_markus) #20

Don’t think so; this issue is at least 3-4y old (in other words as long as I am using OH); this topic has been discussed with some regularity on this forum, but it appears to be super hard to reproduce, some people see it often, others never; for me personally there appears to be also a temporal variable too (for some stretches of time everything works and then it stops updating, etc); a manual refresh always works though…