Basicui: SSE subscription failed: running in fallback mode


after I did some configurations, I get this error msg SSE subscription failed: running in fallback mode in Basic UI.

Can anybody help.


  • Platform information:
    • Hardware: Shuttle Barebone
    • OS: Windows Windows 2012 R2
    • Java Runtime Environment: JDK 1.8.0 191
    • openHAB version: 2.4.0

It’s probably because you use IE/Edge which doesn’t support SSE unlike other browsers:

No, it is the same with Google Chrome, I updated it to the last version, also on two different PCs

Is your openHAB behind a reverse proxy ?
If it is, your reverse proxy setup is probably not good.

OK, that’s it. I have also trouble with the remote Android AP and with the paperui, as I cannot configure some items and some things only work remotely on the Windows machine.

I use IIS as reverse proxy, does anybody know how to configure it properly?

having exactly the same issue but with nginx as reverse-proxy:

server {
listen 80;
listen [::]:80;
return 301 https://$host$request_uri;
server {
listen 443 ssl;
listen [::]:443 ssl;
server_name openhab2.XXXXXX.XX;
ssl_certificate /etc/letsencrypt/live/XXXX/fullchain.pem; # or /etc/ssl/openhab.crt
ssl_certificate_key /etc/letsencrypt/live/XXXX/privkey.pem; # or /etc/ssl/openhab.key
add_header Strict-Transport-Security “max-age=31536000”;
access_log /var/log/nginx/openhab2/access.log;
error_log /var/log/nginx/openhab2/error.log;
location / {
proxy_pass http://localhost:8080/;
auth_basic “Username and Password Required”;
auth_basic_user_file /etc/nginx/.htpasswd;
satisfy any;
deny all;
#### When using Let’s Encrypt Only ####
location /.well-known/acme-challenge/ {
root /var/www/acme-challenge;

I think I solved it by adding these lines just below “proxy_pass …”

     proxy_set_header Host                   $http_host;
     proxy_set_header X-Real-IP              $remote_addr;
     proxy_set_header X-Forwarded-For        $proxy_add_x_forwarded_for;
     proxy_set_header X-Forwarded-Proto      $scheme;

Now I get the same error on the Server with Chrome, so it mustn’t be the reverse proxy. Only with basicui. Any suggestions?

I have the same error. RPI, no reverse proxy of any kind.

ive had better luck with sse and nginx by adding the following.

#This deals with the Aggregating issue
    chunked_transfer_encoding off;
    proxy_buffering off;
    proxy_cache off;

#This deals with the connection closing issue
    proxy_set_header Connection keep-alive;
    proxy_connect_timeout 3600;
    proxy_send_timeout 3600;
    proxy_read_timeout 3600;
    keepalive_timeout 3600;

i was getting random offline messages in basic ui when an item was updated.


Hi, I’m in the same situation. RPI,no proxi and chrome. Contantly get this message.

I too have this issue, no idea what is causing it.

And I have this issue - no suggestions?

[OpenHAB 3.0]
If you use Shift+F12 tools you will see that it is failing while polling the openHAB API for sitemaps.

The trick is to

  1. In OpenHAB -> Settings -> Api Security -> Allow Basic Authentication = true [Save]
  2. Configure nginx for basic auth
  3. Synchronise the openHAB user/password with the nginx user/password. Otherwise the basic auth creds used to get through nginx won’t be allowed through by openHAB
  4. Restart nginx after changing config