Bedroom icon not showing up in iOS app

I already posted this here as a side question but since my main questions there were solved and this question belongs more in this category, I thought I’d post this issue here as well. If you want to look at my .items, .sitemap and .things files you can find them in that post.

The problem is that the standard bedroom icon from the iconset doesn’t show on the app, while it does show up on BasicUI on my pc (the “Slaapkamer” label on the screenshot). I also tried assigning a custom .svf and .png, which both also show up on my pc but not on the app. Weirdly enough the “Woonkamer” label has a custom .svg icon that does show up on my pc and phone.


Anyone encountered this as well? Any fix?

Have you got a mix of bitmaps and vector icons?
When I was setting my up my system OpenHAB didn’t like a mix (not sure if this is still the case)

I only have one custom icon that is an .svg for “Woonkamer”. I tried using the standard bedroom icon, a custom .svg and a custom .png for “Slaapkamer”

I will try removing the custom .svg for “Woonkamer” and check if it will then work for the bedroom icon.

Just removed the custom icons and only used icons that are listed at

Still the bedroom icon doesn’t work for me in the app.

Try changing icon=“bedroom” to icon=bedroom
as this is a default icon I’m not sure you need the speech marks.

I tried also to edit the icon with inkscape and save it but it doesn’t show.
I have also other issues with other svg icons, also causing a crash of the App: it seems the IOS App is a bit buggish (from what I have red it seems it is because svg is not native for IOS and available libraries are not 100% reliable).

@MickUrsell Tried it, still doesn’t work.

It appears to work reliably on my iPhone and iPad.
I have the icon in my items file and not in my sitemap, not sure if that helps?

Group FF_Bed1		"Master Bedroom"	<bedroom>	(gFF)

I also don’t call the bedroom group directly in my sitemap and only call first floor; this the auto generates the bedrooms when accessed

I tried this as well but it doesn’t work for me.

No, doesn’t make a difference either.

I haven’t defined any floors as the place I live at is just one floor so wouldn’t be that helpful.

I doubt there is but any errors in logs?

Have you got another bedroom icon somewhere, causing a clash?

The only other thing I can suggest is create a separate sitemap with just a bedroom and play with defining the icon.

After making any changes it’s worth going through the clear the cache and restart process!

1 Like

I managed to fix it by using custom .png files for the groups and setting the slider to png for the icon type setting in the app’s settings.

1 Like