Binding Aeotec Z-wave 5gen Controller, Qnap TS-253 pro

I have a TS-253 Pro.
I’m trying to get my Aeotec gen 5 Z-wave stick to work with my Qnap. (
I’ve gone trough SSH and done what you can see in the image below.

I’ve done the “insmod /usr/local/modules/cdc-acm.ko” successfully before just did it an extra time for the screenshot.

From what I’ve read I should have gotten a serial port named “/dev/ttyACM0” but I don’t.

I’ve tried all available serial port when binding the controller in openHAB but it just say’s that the controller is offline.

I had to ports called “/dev/ttyUSB0” and “/dev/ttyUSB1” but I managed to delete those trough some tutorial I found on google… (Those didn’t work in OH either)

Any pro tips?

I see in your lsusb you are missing the following

Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc.

I would suggest unplugging and plugging back in to see if it shows up in lsusb or look through dmesg to see if there is any indication there why it didn’t load the hardware. Hopefully Qnap has a dmesg file, I don’t have the hardware in my setup so I’m guessing. :confused:

Hey,Might it be this command that your looking for?:stuck_out_tongue:
I’ve unplugged it loads of times and according to the led on the stick it’s working as intended…

Ok, I’m going to start by saying that I am not familiar with all of the restrictions of the NAS (I think you’re using a NAS). If this is true, are you successfully passing the USB through to the OS/NAS/VM?

What happens if you plug in a USB Drive, is it seen?

Do a listing of ls -la and look for a group of dialout.

Yes, I am using a NAS (Qnap TS-253 pro)
USB drives are seen without any problems. I can’t see the z-wave stick and as I understand it I can’t see it trough SSH either.
I have checked that the USB works on my PC.
Maybe I should just fire up my Raspberry…

List of what? group of what? Sorry I’m pretty new at this…

Sorry, a listing of…

ls -la /dev/*

I’ve tried what it says in that forum thread. didn’t work. Got allot of text doing that command. anything in particular that I shall look for?=P

That post does state

Firmware: 4.3.3 beta

Also you did a dmesg | grep tty, instead try a dmesg | grep usb after you plug it in

Do a listing of your modules, and verify that cdc-acm is present.


If it is not present, then try this command and report output.

modprobe cdc-acm

If it shows, then reboot and verify with


I’m running 4.3.4 so I’m guessing it shouldn’t be a problem.
Saw this when I used that command:

In the end it says it has registred new usb driver “cdc-acm”

Did as you said used “modprobe” and after that I could see cdc-acm. After reboot it was gone again.
But now I see ttyUSB0 and ttyUSB1 when I do the “lsusb” command.

Do modprobe again and then dmesg. Then the ls commands.

Basically the module is not loaded so you effectively don’t have the driver available.

You should be seeing the /dev/ttyACM0 device. A USB labeled tty is not what you’re looking for. Depending on what port it is in you may see a different number other than 0 at the end.

You will likely have to add the module to /etc/modules to get it to load after a reboot. insmod alone does not persist the module after a reboot.

Once the module is loaded, then unplug replug and look for the listing of /dev/ttyACM0. If you now have that you should be on your way. Or at least a little bit further down the road.

I’m curious on why the system posted a usbcore for the driver?

Also are there other USB devices plugged in? It could help with troubleshooting if they weren’t in the system (if possible).

@Gripen Did you solve this? I’m in the same situation.

Thank you.

HI @Gripen Do you fix this?