Binding crash after openhabian-config update

Hi all,

Openhab 3.0.2 (openhabian)
Raspberry Pi 4

After doing a standard “openhabian-config” upgrade system to newest version, they was an “embedded” java update which I (wrongly) answered yes to upgrade.

Now my IHC binding (lights controller) is down.

I get the following:

2021-05-16_12:11:34_CEST [openHABian] Checking for root privileges... OK
2021-05-16_12:11:34_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2021-05-16_12:11:34_CEST [openHABian] openHABian configuration tool version: [openHAB3]{2021-05-05T15:53:37-06:00}(3e35b6d)
2021-05-16_12:11:34_CEST [openHABian] Checking for changes in origin branch openHAB3... OK
2021-05-16_12:11:37_CEST [openHABian] Switching to branch openHAB3... OK
2021-05-16_12:11:45_CEST [openHABian] Updating Linux package information... OK
2021-05-16_12:11:45_CEST [openHABian] Updating repositories and upgrading installed packages...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
N: Ignoring file 'openhab.liste' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

The "ignoring file ‘openhab.liste’…Is new and I suspect that it is causing the issue.

In the “things” tab I get this…

I am pretty lost about this - all ideas would be greatly appreciated as this is a fairly important binding to me:-)
Tried restarting, flushing cache, reinstalling binding.


The file openhab.liste is being ignored. That one is not in use and not causing your problem.
The file was renamed / replaced with an other one because of bintray sunset.
This means repositories are hosted in a different place.

Search for the SSL error message on the forum page or by using google and dong a site search only. This should come up with e.g. this thread: [SOLVED] OH2 & IHC and Java 1.8 - #6 by pauli_anttila
That proposed solution might not work as it is related to Java 8 and not Java 11 that is being used for OH3. I remember that also others have the same problem. So you may search for the other threads.

Ok - thanks for that. My google searches have been focused on the openhab.liste issue as I thought the problem lied there…thank you very much for the link.
The solution refers to a directory (/etc/crypto-policies/back-ends/java.config), but that is not present in my installation (openhab3, openhabian, raspberry pi4). Do you know what the equivalent file would be?


For anyone stumbling into this:
is the directory where the changes can be made.
Now it works! :slight_smile:

1 Like