Binding development Tutorial for OpenHab2

Is there any Binding development Tutorial for OpenHab2 except There are not enough information or even any tutoial for creating a binding.
I just found Information and tutorials for Openhab1.

thanks for help!


for me, the ESH documentation worked for a first start together with peaking into the source code of some existing OH2 bindings.

Note that also refers to the ESH docs:

To learn about the internal structure and the concepts of a binding, please see the Eclipse tutorial on binding development.

Thanks i will work through these links!!!

Hi @Kai,

How do I setup an IDE with the stable release for instance the current 2.2? Within the Eclipse Installer I can only choose as stream the master, which is 2.3.0-SNAPSHOT.
I want to install 2.2.0 (stable) and test my local developed binding, then I want test it on my productive environment.
How do I export the binding from my local development and install it in my productive environment?

If everything works fine then I want to do a pull request.

Thanks in advance for your help.

Best Regards,

How do I setup an environment for binding development. I follow the directions here but, it is fragile at best. Currently I’m getting the following when I click resolve, I get:

Resolution failed. Capabilities satisfying the following requirements could not be found:
      ⇒ osgi.identity: (osgi.identity=org.eclipse.equinox.metatype)

and when I run, I get a lot of missing references and:

Error: Could not find or load main class aQute.launcher.Launcher

I’ve tried deleting my repository and letting it rebuild; no change. Are there instructions somewhere for creating a stable development environment for a binding?

Ed, where you ever able to resolve the resolution issue? I’m running into the same issue on the 2.5.x branch while setting up a new dev environment for a new binding.

Resolution failed. Capabilities satisfying the following requirements could not be found:
  ⇒ osgi.identity: (osgi.identity=org.eclipse.equinox.metatype)
1 Like

Gunnar, I face the same trouble. Did you find a solution?

Please people stop posting unrelated questions to the original topic. Because answering here will burry the correct answer because it can’t be marked as a solution and other people will have a hard time finding that answer.

So open a new topic and I will answer your question and provide some details about what steps you took that resulted in this error message.

1 Like