Binding for Apple-TV

hmm, that‘s strange. do you have a standby time? maybe the background poll wakes it up, which powers hdmi and switches on the TV. Do you see anything in the log at that time?

Nothing this night… Maybe Apple is messing with me or some updates…

ok, make sure to have DEBUG enabled (it if doesn’t mess up your log also TRACE is welcome), so we could see if there is some indication of binding activity beside status polls

Hi everyone,
Thanks for the effort and the binding. I have installed the 2.5 binding to a 2.4 openhab Pi and lost the Paper UI. Does anyone had the same issue?
Thank you in advance.

What dies it mean “I lost Paper UI”

I saw this above

@jacksteraz could you please provide details what your situation has been and how you fixed it.

I’m not aware of this issue, but who knows…
Dis you copied the binding jar into the addons folder when openhab was stopped or while OH was running?

If it helps I could provide a 2.4 build. Not
sure if this makes a difference.

Which platform are you using (OS, version, OH)?

After I cleared the cache using a command like:

sudo service openhab2 stop && sudo rm -rf /var/lib/openhab2/cache/* && sudo rm -rf /var/lib/openhab2/tmp/*

and went to log into openhab at 192.168.x.x:8080, paper ui was no longer an option. This didn’t have anything to do with your binding, it had to do with clearing the cache. So no need to make a 2.4 version.

@ Normann_P_Nielsen I have have also noticed that the TVs that are connected to Apple TV turn on unexpectedly in my house. The reason is that I turned on the HDMI CEC or ARC control. Whenever your binding restarts, it send a “top menu” command, which wakes up the ATV, which then turns on the TV.

Hi Markus,

What exactly did is that I stopped the service, remove the old .jar binding, clear tmp and cache, paste the new 2.5 binding, start service and reboot the pi just in case. From that time and on when I was browsing in the openhab 8080 port there was no “Paper UI” nether some other two options (I cant remember). Finally I replace the new binding with the old one and that fix the issue.

I hope that helps,


I’ll create a version in the 2.4 build environment at the weekend, that’s the only difference I could think of - strange.

Hi, here is the 2.4 build
I seems that a 2.5 build has issues on OH 2.4, so I’ll stay with 2.4 until a new stable release is available.

This version also doesn’t send a top_menu when the binding starts (only alpha2 does).

@jacksteraz @ciscomike Please provide feedback.

you should use “open-hab-cli clean-cache” command.

Hi @markus7017,

today I had to some time to renew my appletv binding.

And I have to say that everything worked immediately! Good job! Best user experience. Nothing to add. :slight_smile:

I am on 2.5 M1 on a Raspberry Pi with openHABian.

Have a nice day and keep up the good work!

Hi @HFM, thank for your feedback. Most users post only issues etc., but it’s always important to see what’s the adaption rate (pos. feedback) and, which versions are used etc. - so thx. again

What ware your experiences with 2.5M1in general? I’m not sure if it’s stable enough to run my environment and it seems that there will be significant delay for the next milestone build, because the core team is working on bnd adaption and OH 3.0 in general.

Hi @markus7017,

I think you made a fine piece of software and that should be said! So I speak out loud. :wink:

In general 2.5M1 was good step forward regarding MQTT2. That was my main reason to switch because 2.4 was so buggy. Now I have some issues within my Zwave that appeared after 2.5M1. So I have to restart in between times - more than in the past. It’s annoying but no major break. At the beginning I had to sort out some things, but I do not remember anymore what it was exactly…

Hope, this helps to think about.


Hi Markus,

For some reason, the link is not working for me. Maybe because I was late.

Thanks again,

try this

Hi markus,

Thank you for your prompt reply, yes now is working fine.


Hi guys,

was testing a little bit with the remote key. My problem is that I have different results from different starting points. Starting in the 1st and in the 2nd row ends in different places although everything should point to the same place. I think the reason is the strange handling of the “top row” (e.g. last seen). If I am in the 1st row a “up up up up” ends in top row. If I am in the 2nd row a “up up up up” ends in 1st row, like a hidden wall. Or do I miss something?

So I want to ask if someone has a best case from you.

Have a nice evening!

stupid but simple

top_menu up up up up up left left left left left

should bring you in the upper left corner, then start to navigate to your destination

there is no key like home and there are points they the remote doesn‘t work

is not stupid when it works :slight_smile:

Hey @markus7017,

did not work for me.

I tried multiple scenarios:

  • 3rd row within app
  • 2nd row within app 2nd level (like Amazon Prime and then chose something)

It was always stuck on the app icon.

What helped me was:

top_menu menu menu top_menu

BUT with a 501ms delay between the commands. On a first try this seemed reliable.

What time do you use for chained commands in your binding?


P.S.: I use a AppleTV 4K and tvOS 12.3. Is there a difference to others?