Binding not appearing in clean Eclipse in OH4.0


I had issues with my git branch so I made a new clone. Since then I am not able to continue developing my binding as it does not appear in the Main UI/Things/Bindings.

I even made a clean install of Eclipse in Windows deleting .m2 folder .p2 folder. I am running Eclipse on a Windows machine with JavaSE-17.

My console output when I start is:

! 10:40:12.081 [INFO ] [org.openhab.core.Activator          ] - Starting openHAB 4.0.0 (build Unknown Build No.)
10:40:13.706 [WARN ] [ce.jetty.internal.JettyServerWrapper] - Can't create temporary directory for OsgiContextModel{HS,id=OCM-17,name='context:1275119693',path='/',bundle=org.apache.felix.webconsole,context=WebContainerContextWrapper{bundle=org.apache.felix.webconsole_4.7.2 [50],contextId='context:1275119693',delegate=org.apache.felix.webconsole.internal.servlet.OsgiManagerHttpContext@4c00c84d}}: C:\Users\chris\AppData\Local\Temp\ROOT\context:1275119693
10:40:19.262 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.items'
10:40:19.877 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mapdb.persist'
10:40:20.220 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.sitemap'
10:40:20.450 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.things'
10:40:24.052 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'demo.rules'
10:40:34.076 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
10:40:34.114 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DemoLocation' changed from NULL to 52,9
10:40:34.115 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DemoContact' changed from NULL to OPEN
10:40:34.116 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DemoString' changed from NULL to Hello SmartHome!
10:40:34.117 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DemoDateTime' changed from NULL to 2023-03-26T10:40:34.071038400+0200
10:40:34.127 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'DemoNumber' changed from NULL to 12.34

The Binding is linked in the pom.xml of the like this


I have added it in the app.bndrun, resolved it and saved it.

No clue why it isn’t working anymore.

Any hints?

Do you have added a addon.xml file? Here an example from my addon:

No, Is that new with 4.0? I did not do this before and it worked. I will try.

I do have that file. However it is still not working. Any suggestion?

I reinstalled again. Now it is working. Don’t know what caused the problem

It has something to do when you build the jar file with Maven on the command line in Windows and when you build it through Eclipse.

Any thoughts?

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.