Binding Sonoff with LAN Control (firmware >=1.8.0) without tasmota?

Using Lan control, can you bind sonoff without flashing?

Can you explain this video, I’d love to have my sonoff’s connected to openhab, and I’m not going to flash them.

You can also use ifttt, if you don’t mind some latency.

@chasemixon curious, why would you not flash them if you are interested to tie into openhab?

@anoxiety i have seen blog posts stating this is possible. I tried it because it looked easy, but i quit when i realized how easy it was to reflash. I reflashed a couple of mine iver the air. Some failed due to incompatible version for ota flash.

I highly suggest a reflash if you plan to use with openhab. The reason for reflash is that you get so many more features. The only loss is the ewelink app, but openhab replaces this. You can still tie into alexa and google through openhab.

1 Like

I agree with flashing and you dont have to solder anything but I do because I can then use the GPIO 14 for other things.

If you take the plunge, I recommend looking at Atom with platformIO for flashing. Much better IMO than the Arduino IDE.

1 Like

well honestly, I’m lazy, they are already installed, and I didn’t think the ota worked anymore? back when I was looking at doing it, the flashing required soldering, and I do what a vacuum does when it comes to that! :wink:

can you have a step by step for dummies…?

The latest Sonoff basics are not so easy to solder. But you can do it without soldering.
Just need to find a way to hold the wire steady during flash (by hands or with some kind of Blu Tack) Someone designed a clamp with a 3D printer but I can’t find it now.

I understand people who wants to keep the original firmware tho.

I have some ledstrip that can be flashed with tasmota, but I prefer to keep them working with the original smartphone app. Not much value added with Tasmota on this hardware, because they’re is a binding in openhab to control them.

For Sonoff switch, adding MQTT is so much improvement, and I remember the few times when ewelink server where down …

I would always flash a device relying on a Chinese based cloud. You don’t know what data these apps and clouds are gathering about you and you have no way to hold them accountable for it.
I have read tales of cheap Chinese devices with their own could and app waking up by themselves and doing odd things including a camera turning on and starting moving in the middle of the night!
The Chinese have a very different point of view on privacy than we have in the west and it when we buy these devices we need to be aware of that.
I trust only two clouds, mine and myopenhab. I have to use goggle but I only put non critical things in it.

I short, flash it. It’s easy. You get YOUR device and YOUR data. And the functions available on tasmota (for example) are far better that what you get from the app.

@chasemixon I am working on a blog post on this topic. Will post when finished. In the near term I can say this. If you have some of the dupont wires thats what I used, no solder required. I just held them in place.

I then put some clear tape on them. I used an arduino as my usb to serial interface. You can do this by jumpering reset to ground and then transmit and receive can be used to pass data through.

I followed this: tasmota but first you have to clone the tasmota git repository to you computer and then I used platform io. Following this guide: and this video:

The video helps quite a bit.

Links to all tutorials: tutorial

You don’t even need PlatformIO
You can download the binaries directly and upload with esptools
That’s what I do. No need to faff about with source code and compiling

@vzorglub thanks for reminding me of that.

I had to compile when I did it. It was due to a memory error being reported. In the end, I don’t know what the problem was, but the tasmota file I had didn’t work. Probably grabbed the incorrect one. You know how you lose focus, instead of download a new file spend an hour learning platform IO. LOL!

In the end, it was a blessing as my wifi settings were in my personal binary.

FYI if using tasmota firmware and having issues re-flash and select Esp8266 core for Arduino version 2.3.0 from the platformio.ini file. There is a known bug in 2.4.0, it may have fixed by now but 2.3.0 works solid.

Reading the flashing without soldering, I can confirm that just holding the cable from the picture while flashing was enough. It migth not work on the first try but it works.
As long as you don’t need a sonoff RF you can get around soldering. I bought my sonoff RF already flashed :wink: (for 5€ more compared to the price from the manufacturer).

May I propose using the binary straight from with esp easy flash software. This way you don’t need to compile.

If you want to try to compile have a look at the quick pi video I posted above. That worked for me with no issues.

Thats the video guide I used when doing my first ever sonoff flash. :sunglasses:

Sorry, didnt realize. Just wanted to make sure. I understand how getting all the libraries together is hard. I could not get tasmota to compile in the arduino ide etiher. So, I aborted and went to the platform io. I must have been lucky and had all the correct versions of things.

Not a problem, glad you posted the link, IMO it’s the best video for a first timer. Short, to the point, and it works!

You can use Platformio with VSCode as well. For me, I use Platformio and ATOM for all my flashing needs and VSCode only for OH. Maybe its just me, being lazy or scared, but when I have something working, I prefer not to mess with setting until its necessary.

I am same way here. If not broke don’t fix!

1 Like