Bitron Video ZigBee USB Funkstick stops working after a while

Tags: #<Tag:0x00007f434cd8c7f0> #<Tag:0x00007f434cd8c110>

@5iver I’m on Openhabian in a RB Pi 3 Model B. I don’t know where to check that or if it is applicable in my system

power mgmt for USB devices is a Windows thing - it causes in many other HW cases some troubles. However you can find it in linux as well, but I never came across it

if it helps I’ve added all the system info I could gather (and fixed the logs format)

It would be good to get a full debug log so I can see if it’s caused by communications issues with the dongle, or if it’s a network issue.

I would also probably suggest upgrading to a more recent binding (ie the snapshot) as the M1 version is now quite old.

I cannot upload the log file because I’m still a new user, but here you have it: https://drive.google.com/open?id=1gMWPThajLsX75RlXqr3nnZh1epUIa-E7

How do I upgrade just a binding?

This script is the easiest way. You need to uninstall the old binding first though.

The script will uninstall it for you, whether it was installed through a UI, the console, or manually.

1 Like

I tried the script but it doesn’t seem to work:

It has taken more than two minutes to uninstall the Zigbee binding, so exiting

I checked the Zigbee version in Paper UI and it’s the same that I had: binding-zigbee - 2.5.0.M1

Shall I uninstall it manually before trying to upgrade? Should I remove all the things as well?

You could or, if you wait a little bit, 2.5M2 may be out.
They are sorting through final build issues now.

EDIT: Kai has given up on M2 build until tomorrow.

There are lots of things that can cause this. Usually, it’s an issue with the REST API (used when checking if the binding is uninstalled and then installed). Restarting OH sometimes helps. If not, try manually removing and then try the script again. The readme in the repo for the script lists all the manual steps needed, so you can do it that way too.

1 Like

I uninstalled it using PaperUI then I could run the script.
I updated the Zigbee binding but now the BV 2010/10 (ZigBee USB dongle)fails to be online, no matter what port I use… I’m about to give up and start over with a fresh new install.

I could not get the zigbee binding to run as a manual install using a snapshot build of OH. You are using 2.5M1, which others have reported this working on, but the libraries were recently updated, so something new could be happening. First, double check your binding and library versions by running…

list -s | grep -i zigbee

… in the Karaf console. Next, post a log of an OH startup with the logging level for the zigbee binding set to debug. Chris is the maintainer and most qualified to help with this, but he is traveling and may not be available.

Maybe it is not even a problem stick, but a problem in the power supply of the Raspberry Pi. The USB port are turned off in the event of undervoltage first. Check your Raspberry for undervoltage. If present, replace the AC adapter or USB cable. Pay attention that it is a USB cable that is approved for fast charging.

1 Like

Unfortunately this isn’t so helpful. I really need to see the debug from the dongle driver to see if I can spot what is happening. You need to also enable this debug as per the docs -:

log:set debug com.zsmartsystems.zigbee

Will do, thanks for the tip.
I reinstalled OH 2.4.0-1 in my RBPi and I’m adding all the devices that I had, so far jut Zigbee ones, it seems to be working for now.

1 Like

And it happened again. Zigbee stopped working. Coincidentally I had just added the Zwave dongle and upgraded it to 2.5.0 (just the Zwave binding) so that my switch was identified.

I even tried to reboot the system, first time it didn’t pick up the port, second time it did, all but one of things appear in green in Paper UI but I don’t see them updating in the log.

I managed to get the debug logs at least of the last session that starts around 22:36.

UPDATE: I just realised that the por is not selected in the parameters and the USB port doest not exist but I can see the device in linux shell… weird

[23:25:11] openhabian@openHABianPi:~$ lsusb
Bus 001 Device 006: ID 10c4:8b34 Cygnal Integrated Products, Inc. 
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

42

My Specs:

  • Hardware: Raspberry PI3 Model B (ARM)
  • OS: Raspbian GNU/Linux 9.9 (stretch)
  • Java Runtime Environment: Zulu8.38.0.163-CA-linux_aarch32hf / build 1.8.0_212-b163)
  • openHAB version: 2.4.0-1
  • Zigbee binding: 2.4.0 (1.1.6 )
  • Zwave binding: 2.5.0 (upgraded using the script)

What version (exactly) of the binding are you using? I don’t think it’s the latest, and in this case I’d recommend to update.

I don’t think that will directly help though, but it’s always best to start with the latest and the latest binding has a reconnect feature which may work around the problem - depending on what it is.

The log doesn’t really indicate any major error, but it seems to stop communicating with the NCP and the TX queue starts increasing. This could be an issue with the serial port.

It’s interesting that the problem starts when you plug in the ZWave dongle - maybe your computer briefly disconnected the serial port when this was plugged in and that stopped the ZigBee binding communicating. There is no direct link between the ZWave and ZigBee binding other than the OS and the USB.

Jostling a bad cable or connection could cause that too,

Well, I’m using the official RPI power source and although the two dongles have a limited space (see the picture) I don’t think that there is a connection problem. Anyway, I’ll use a cable extension for one of them and see if it helps, I think that I’m in that moment where I would try anything.

:smile:

@chris here you have the versions, do you want me to start from scratch (fresh system) from the 2.4.0 and then upgrade the bindings to the latest using the script?

200 │ Active   │  80 │ 1.1.6                  │ com.zsmartsystems.zigbee
201 │ Active   │  80 │ 1.1.6                  │ com.zsmartsystems.zigbee.dongle.cc2531
202 │ Active   │  80 │ 1.1.6                  │ com.zsmartsystems.zigbee.dongle.ember
203 │ Active   │  80 │ 1.1.6                  │ com.zsmartsystems.zigbee.dongle.telegesis
204 │ Active   │  80 │ 1.1.6                  │ com.zsmartsystems.zigbee.dongle.xbee
211 │ Active   │  80 │ 2.4.0                  │ ZigBee Binding
212 │ Active   │  80 │ 2.4.0                  │ ZigBee CC2531 Binding
213 │ Active   │  80 │ 2.4.0                  │ ZigBee Ember Binding
214 │ Active   │  80 │ 2.4.0                  │ ZigBee Telegesis Binding
215 │ Active   │  80 │ 2.4.0                  │ ZigBee XBee Binding
218 │ Active   │  80 │ 1.4.7.1                │ Apache ServiceMix :: Bundles :: xstream
219 │ Active   │  80 │ 2.5.0.201908091758     │ openHAB Add-ons :: Bundles :: ZWave Binding

I would certainly suggest to use the latest binding as 2.4 is now very old and there have been a lot of changes since then. I’m not convinced that it’s related - as I said I think that if this happened at the same time as the ZWave dongle was inserted, then maybe there is an enumeration issue in the RPi, but updating to the latest is highly recommended in any case.