Blank dashboard page - locale error

  • Platform information:
    • Hardware: armv7l
    • OS: Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
    • Java Runtime Environment: openjdk version “11.0.2-BellSoft” 2019-01-15
    • openHAB version: 3.1.0 - Release Build
  • Issue of the topic: Getting a blank dashboard page - Worked before, set up username and password, added some addons and still everything worked fine, after an hour or so of idle, refreshing the dashboard resulted in a blank screen.

When opening devTools in the browser (Chrome Version 94.0.4606.71 (Official Build) (x86_64)), I receive this error:

app.js:formatted:71149 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'locale')
    at u.loadRootResource (app.js:formatted:71149)
    at Array.<anonymous> (app.js:formatted:48886)
    at u.dispatch (app.js:formatted:49018)
    at u.dispatch (app.js:formatted:48695)
    at app.js:formatted:69542

(Tried formatting it and debugging it a bit before sending, that’s why it’s formatted.

For what it seems, it looks like I have a problem with my locale. I used en_IL and then after researching a bit I changed /etc/default/locale file to en_US, restarted the service but did not seem to help.

Thanks in advanced for any help. :slight_smile:

Not shure if it will solve your issue, but you are using a not recommended Java version.
Please read the prerequisites and move to Zulu 11.

Thanks for the quick reply. I will try that. I will also mention that it did work before.

Java version updated to Zulu:

openjdk version "11.0.3" 2019-04-16 LTS
OpenJDK Runtime Environment Zulu11.31+16-CA (build 11.0.3+7-LTS)
OpenJDK Client VM Zulu11.31+16-CA (build 11.0.3+7-LTS, mixed mode)

Still receiving the same error.

Edit: Also restarted the service. Is there any way of seeing the unminified and uglified source code of the dashboard so I could debug it?

Managed to get it working. Now I was cautious and backed up my /opt/openhab folder. Reinstalled openhab and set the locale to en-US. Still not sure why this error happened.