Blockly UI not showing up

I am working for a OH3 setup, beginner.
Finally I got it working (HTTP and MQTT for the beginning)
Frontail still needs fixing.(headaches with the installation, a lot of headaches with the configuration, service is running but web interface is not available)

I wanted to have Node-Red working with OH3 but the fix found on the community is too elevate for me.(I did’nt catch the API token stuff and how to’s)
So I tried Blockly (one friend suggestion) with no luck.
The Blockly user interface does not show up. I get the text script interface instead.

Requested content not found.

Debug information
Url: /settings/rules/f54df56f0a/module-config
Path: /settings/rules/f54df56f0a/module-config
Route: (.*)"

My setup is Odroid C2, Dietpi, openhab 3.2.0
Any help?

Show us some screen shots of how you create the rule and the script action, step by step so we can see what you are seeing. Note that you must select “Blockly” from the list when you create a script action or script condition.

Thanks for the response.
There is nothing to show.

Create rule (give a name) > Add trigger (choose from items) > Add action >
when I press “Design with Blockly” there appears the script text editor, no Blockly UI.

Nothing apparent to you but we here know what it’s supposed to look like. Things like URLs, titles of pages (or lack thereof) and stuff like that actually give us useful information. If you knew what to look for you wouldn’t be here asking for help. If there was nothing useful there I wouldn’t be asking for it.

Without more information. :person_shrugging: It’s broken is about all I can offer.

One friend which helped me with the OH setup showed me remotely how should it look.(different coloured blocks to choose and place)

I only get the script text editor.
I can place here a screenshot with the script editor but what can this help?

OK, that provided crucial information.

Where are the other scripting languages? There should at least be Rules DSL and ECMAScript 5.1 listed under “or choose a scripting language:”. Those come with OH, they should always be there.

Without at least the 5.1 ECMAScript Blockly can’t work because it gets “compiled” to that language to run.

First, restart your browser to eliminate the possibility that something wrong is cached and that you get a fresh MainUI.

Then if that doesn’t work, restart openHAB and watch openhab.log for errors, particularly errors that talk about automation.

If there isn’t anything in the logs we’ll go to the karaf console next.

If restarting openHAB does not fix it, try a recent milestone which has this fix that should help:

If you also use Java 15 or newer, then you’ll need the old JavaScript engine for using Blockly by installing this Marketplace add-on:

I do not think restarting OH helps.
OH version installed is latest stable available, 3.2.0

It is possible Java/Node to be screwed after installation because I installed Frontail which seemed to replace Node.

How does this look?

root@DietPi:~# node -v
root@DietPi:~# java -version
openjdk version "17.0.2" 2022-01-18
OpenJDK Runtime Environment (build 17.0.2+8-Debian-1deb11u1)
OpenJDK 64-Bit Server VM (build 17.0.2+8-Debian-1deb11u1, mixed mode, sharing)

See Installation Overview | openHAB where it says:
Please note that versions of Java higher than 11 are not supported at the moment.

Some have made newer Java versions work, but it’s probably easiest for you if you install Java 11 for now.

1 Like

Downgraded java to v11.
Blockly works now.

Thanks jswim788