Bluetooth of Pi within Docker

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
      Pi 3B+
    • OS: what OS is used and which version
      Docker
    • Java Runtime Environment: which java platform is used and what version
      Docker
    • openHAB version:
      2.4.0-armhf
  • Issue of the topic: please be detailed explaining your issue
    Hi I run openhab in a raspberry pi docker in privileged mode and try to use it’s internal Bluetooth with the binding but had no luck…has anyone tried a similar setup, also encountering problems?
  • A: Do you run the docker in networkmode = host?
  • B: Have you tried using bluetoothctl to see if it can see your devices? you need to verify bluetooth is working on host OS first

A: yes
B: yes the Bluetooth is working on host

I currently use raspberian lite as host

Anyone with a solution/same issue?

Indeed. the same config (hardware/software), the same issue with no working bluetooth.

My fix was to stop use docker for open hab and go back to host installed software what i do not prefer now.

regards
m.

Same issue here, on openhab 2.5

Also still the same here…

Any news on this?

Edit: I moved this to development, as I don’t know if the issue still exists in OpenHab 3…did someone test this? If it’s working we can mark a solution here :slight_smile: