BMW ConnectedDrive Binding


I dropped the latest .jar into my add-on s folder but I can’t install/reach the binding.

(OH3.0.1 Synology/Docker)

could you give any help
thank you


What does that mean exactly ?

Manual added bindings will not show up under installed bindings. You need to go to things and then press the big blue button with the plus symbol located to the lower right to add a new thing. The following dialog should thow the bmwconnecteddrive binding…

yes, idid it, but nothing, clicked the blue + button, the installed bindings has been listing, nothing else.

So you don’t see the binding when pressing the plus button ?

Please go to openHAB’s KARAF console (openhab-cli console) and enter the following


you should see the bmwconnecteddrive binding as one of the last entries.
If found, what is the state, installed or active ?
If just installed, enter

bundle:start <number of the binding>

if it now shows active, try to add a new thing again.

it looks like it has been installed, but gave me an error

@weymann Could you please create a .kar file (mvn clean install karaf:kar) and post a download link here. This would solve the unresolved requirement issues some users see.

1 Like

Done. Can be found in the OH3 link from top post.

1 Like

Great, thanks @weymann

You’re right, looks like another API change. I’m sure you’ve seen this rebase commit in bimmer_connected but for the benefit of others following this thread, it looks like things have changed once again.

I must add that climate control still works at least! I only discovered this today when I thought I’d give that a try

First thanks a lot @weymann for the effort :slight_smile: I recently installed the binding and got all working with your latest binding … now since a day or two the remote control will create an “Climate Now Error 500” in the Service Execution State (= online) … also restarted the binding … no success… mobile app is working fine…
Any hint highly appreciated :slight_smile:
LOG: HTTP Error“MyVIM”/executeService - 500 - Internal Server Errornull
(other info I use it works just fine…)

just in case relevant: [ternal.handler.VehicleChannelHandler] - VehicleStatus switched to legacy mode

1 Like

same here. Binding was working well - since some days I see a “Climate Now Error 500” when trying to start the AC. It was working for months.
(currently running OH3.2M5 - also tried manual install of org.openhab.binding.bmwconnecteddrive-3.2.0-SNAPSHOT.jar)
If I can help by e.g. delivering more log files or testing new beta-versions of the binding please let me know :slight_smile:

I think since yesterday everything is down. All API calls are responding with status 410 - Gone. There’s no problem in the binding, BMW simply changed their ConnectDrive API to new MyBMW API. Rework is needed.

1 Like

This would have likely been due to AWS going offline for a period of time yesterday. Cause a few web services to go offline.

@weymann are you able to identify the changes BMW have made and therefore update the binding?
Before it BMW broke it I had a number of rules in place that my Wife found very useful, one being that she could get me to run her a bath ready for when she gets home. Now she has to phone me instead of just getting in the car and driving home.

1 Like

I’ll start adaptions this year. At the first glance their will be several changes

Not supported anymore

  • statistics for last trip and overall trips
  • last destinations


  • charge history

No solution available yet

  • send charging profile

Hi! Any news about the adoptions to the new API? In the BMW i3 Forum (Geniales iOS14 Homescreen Widget Script für SoC, Reichweite, usw. - Seite 12 - i3 - Allgemeine Themen • BMW i3 - Elektroauto Forum) I found a thread with a similar problem. They said only the url has been changed
" Die “alte” API funktioniert nach wie vor.
Lediglich die URL hat sich anscheinend von “” zu “” geändert.
Die “” wurde als Zugangspunkt zur API anscheinend abgeschaltet."
Is it really that simple?
Best regards

The problem metioned is different. Since te beginning / .us / .cn for US or China are used. Just to highlight: this binding is still working! Values regarding ddors, windows, charging, range, warnings, services, … are correctly delivered by the current API. But values for

  • Lifetime statistics
  • Last trip statistics
  • Charge profile get & set
  • Last destinations

are not working anymore. And this is not due to changing the server. The BMW ConnectedDrive App is deleted from Android App store and the replacement is the MyBMW App. With this App many things were changed

  • Login & Authorization flow
  • Server and APi signatures
  • returned data structure and values

First prototype is wprking but it’s too early to distribute.


First of all, great job with the binding. I appreciate the work you put into keeping the BMW binding operational!

To clarify your latest update; are you saying remote control through the binding should still be operational? Similar to a couple of other users in this thread the last couple of weeks I am only getting 500 errors whenever I try to send a remote control command (doesn’t matter which one). So if there’s no problem with the binding in this regard I assume there is something wrong with my setup?

You’re correct. Tried several times today execution of remote services but got every time Internal Server Error 500. This was still operational ~ 3 weeks ago. So it seems BMW cancelled also this functionality.
So to say: the functionality is reducing more and more. But I doubt this can be fixed using the API currently in use. Project bimmer_connected already switched to a new BMW API which I’m currently implementing.


Here we go => MyBMW Binding