[bosesoundtouch] Binding is not connecting to Bose SoundTouch Wireless Link Adapter

I have an problem with the connection to the Bose SoundTouch Wireless Link Adapter.
I have two devices:

  • a SoundTouch 10 where the comunication works
  • a SoundTouch Wireless Link Adapter where the communication is not working. The only error message a can see is in the PaperUI is if I create or modify the thing. The error “Status: OFFLINE - COMMUNICATION_ERROR Connect Timeout” appears in the Thing (PaperUI).
    Both devices a working great with the Bose app but a cannot get the Link Adapter to work with Openhab 2.
    I tried to debug where the problem is but the set of “log:set DEBUG org.openhab.binding.bosesoundtouch” didn’t change anything in the logfile. No error messages.

My Config is:

  • Manual configuration with ip of the Wireless Link Adapter an the first mac address.
  • Rasp. 2. and Sound device are in different networks. A firwall is routing the packets between the devices. (this is the reason why auto-disc. didn’t works. It works with the Soundtouch 10 in same enviroment).
  • Openhab 2.3
    If would be great if someone could help me.


I found the problem myself. It’s a eclipse smarthome binding and not a openhab2 binding. So the debug command is:
“log:set DEBUG org.eclipse.smarthome.binding.bosesoundtouch”.
The problem itself was a network configuration problem. For the Soundtouch 10 the source ip of the request seems not to be relevant. For the Wireless Link Adapter the source IP of the request (in this case openhab IP) has to be in same network as the device itself. I managed it with the firewall and it works now.

Hi Markinus,

It’s quite amazing that the ip of the managing device has to be on the same network. Okay, in my env the openhab is on the same network than the soundtouch speakers but some of my mobile phones managing the speakers are on different networks and i havn’t issues seen similary to this. Do you have a chance to test a device with the soundtouch app (dosn’t matter if it’s a phone or a desktop with the soundtouch app) if this also apply’s to it? I assume it also must happen there…
For me it seems to work flawlessly - but i don’t have a “Wireless Link Adapter” in my setup, only Soundtouch 10/20/30 speakers…


Hi marvkis,
I know this problem from my Panasonic TV, there it’s exactly the same problem. But I didn’t expect the difference between this both devices. But it is. I tested it in the end with my PC. I connected first to the IOT network and put a http://:8090/info. I received from SoundTouch 10 the XML reply but from the Link no answer. Like it wouldn’t exist. After direct connection to the MEDIA network I get two replies immediately.
The app works, only for the first configuration I had to connect to this network directly.
Maybe they are communicating over the cloud…