Brennenstuhl 433Mhz radio-controlledockets dont work

  • Platform information:
    • Hardware: Raspberry Pi 3b // 64-Bit Quadri-Core ARM Cortex-A53
    • OS: openhab for Raspberry PI
    • openHAB version: Openhab 4
    • radio-controlled sockets: RCS 1000 N comfort
    • 433Mhz system: 433Mhz

Hi everyone,

I’m new to the openhab world and just trying to control my Brennenstuhl radio-controlled sockets (433Mhz) via openhab.

For the setup I used the following instructions:

The setup basically worked well and I was already able to switch one radio-controlled socket.

Here is my issue:
I can only switch one of my 6 sockets.
Socket A: DIPCode - Channel 4 Button A
Socket B : DIPCode - Channel 4 Button B

Socket A can be switched from the beginning without problems, but socket B cannot. Even if I set socket B to the same DIPCode, it will not switch. I have tried all 6 sockets and only socket A works.
In all DIPCode variants, the sockets can be switched via the supplied remote control but via Openhab always only socket A.

I have also already run a sniffer and see that Openhab sends the codes itself, but the reaction of the socket remains off.

Do you have any idea what the problem could be?
What information do you need for a better analysis?

Thanks and greetings

Timing issues (one socket is more tolerant of timing erros)? Stop all processes that are not needed for sniffing/sending (e.g. openHAB) and try again.