Brightness receiving command going down, back up and down

  • Platform information:
    • Running on Raspi 3B+ with Openhabian installed, updated to newest developer version
  • Issue of the topic: Best shown in the log i paste, somehow the light does not simply go to the commanded value, it jumps back up and down.
  • If logs where generated please post these here using code fences:
2019-11-08 15:03:46.039 [ome.event.ItemCommandEvent] - Item 'Brightness_Washing' received command 10
2019-11-08 15:03:46.054 [nt.ItemStatePredictedEvent] - Brightness_Washing predicted to become 10
2019-11-08 15:03:46.076 [vent.ItemStateChangedEvent] - Brightness_Washing changed from 15 to 10
2019-11-08 15:03:47.151 [vent.ItemStateChangedEvent] - Brightness_Washing changed from 10 to 15
2019-11-08 15:03:52.207 [vent.ItemStateChangedEvent] - Brightness_Washing changed from 15 to 10

Perhaps you are rolling the device too frequently. When dimming it takes time for the device to fully execute the command. If you poll too often, you will see intermediate states.

well, i just have a rule showing when the brightness has been changed, but you can actually see the light brightness going up and down…

This has to do with autoupdate which is enabled by default.

When you send a command to an Item, that command itself doesn’t result in an update to the Item’s state. When autoupdate = true, the autoupdate mechanism will “predict” what state the Item will become and issue an update to the Item automatically. When autoupdate = false, the Item will not change state until something else (usually the binding) issues an update.

What is happening here is you issue the command 10, autoupdate is predicting the Item will go to state 10 so it issues the update, the binding receives and update saying the device is at 15 so the binding issues the update changing the Item back to 15. Finally, the binding is informed that the device has responded to the command and issues the update to the Item to 10.

So you either need to get the binding or the device to not report it’s state before reacting to the command, or you need to turn autoupdate=false so the command doesn’t prematurely set the Item to 10, or you just need to understand what is going on and live with it.

That might point to something different going on. And that something is going to be in the binding or the device themselves. The logs presented show that OH is only issuing the one command and everything else is OH just being told what the device is doing.


thanks for that explanation, i was not aware of that functionality.

i switched autoupdate to false and will see how the behavior is now.

Go into Habmin> Configuration> Things> select your device> Device Configuration> Command Poll Period. This setting gives the binding an interval after which it should poll the device after it has been sent a command. This is useful for devices that do not report their state, but most device report their state on their own. The autoupdate profile does not have anything to do with the Command Poll functionality.

If your device reports its state on its own (you did not include the type of device, so I can’t help there :wink:), then set this to Disabled. If your device does not report its state, then gradually increase the interval until the device physically completes the state change before it is polled.

IMO, the binding should have this setting disabled by default.

@5iver Ok, the device is actually a Zigbee Light from Osram and i am trying to gradually dim down the brightness, when no motion is present in the room.

Under Habmin - Configuration - Things - OSRAM KG (my Osram lamp) - Configuration (the little wrench) - i have 2 Config Parameters -Light ID- (well, the id for the Zigbee light) and -Fade time (says Fade time in ms for changing values) - which is set to 400 ms. I guess that is the value i have to experiment around with.

Sorry about that… made the bad assumption that you were experiencing this with zwave devices, since this is a common issue people have reported. The zigbee binding does not have Command Poll Period, but what do you see under Channels? For my zigbee Things, I see a number configuration options under the Channels, but I’m not sure if those will help you.