Broadlink binding for RMx, A1, SPx and MP. Any interest?

Happy new year

Is there a version of the addin compatible to OH 3.0?


meneldor i didn’t see working solution for SP3S. Maybe some hardware problems, to get power consumption data?

Hi everyone,
As per @nakh_Home asked, is there any update about OH3 binding?
Thanks a lot and happy holidays!

Hi All,

see also OH3 UI IR widget

Thanks for all the good work
Happy holidays


@Cato_Sognen Hey :slight_smile: I just upgraded to OH3, just missing custom .jars for Plex and the broadlink rm3. Do you think we will get a ported version for OH3? Does anybody else knows the current state of development?

Cheers and happy holidays :slight_smile:

Going to try and get an OH3.0 compatible build out in the next couple of weeks.
Sorry for people who’ve been waiting patiently for this! :frowning:


Hi, thank you for your efforts, I am happy to test the builds with you :slight_smile:

Happy holidays :slight_smile:

Thanks bro… have a nice holiday

I’m hoping to get some time to take a further look at the BG Electrical wall socket in the next few days. I’ve also bought two of their adaptors for cheap off Amazon. Seems to be compatible with the SP4b so I’ll try adding that as a merge request first (low hanging fruit and all that).

Log output:
2020-12-29 14:58:10.295 [ERROR] [nding.broadlink.internal.ModelMapper] - Device identifying itself as '20962' (0x51e2) is not currently supported. Please report this to the developer!

Google result from HomeAssist: SP2-UK broadlink smart plug Unsupported device: 0x51e2 · Issue #44216 · home-assistant/core · GitHub

Model Product Page: Smart Sockets | BG Electrical Accessories

Hello Friends,
When I turn ON a particular Zwave switch, I would like to create a rule that automatically sends a turn ON command to my RF devices using the Broadlink binding.

I tried these two commands format, but I failed to make them work:

sendCommand([itemName], [command])

For [itemName], I used the command string item I created for the Broadlink Command Thing (I called the item: rf_control).
For [command], I used one of the RF codes titles I entered in the file to set the bedroom fan to speed 1 (bedroom_fan_1).

For example, When I switch ON the bedroom’s fan zwave wall switch, I would like the Broadlink binding to send out an rf command to turn ON the bedroom fan to speed 1, so I tried these commands but they didn’t work:
sendCommand(rf_control , bedroom_fan_1)

Any ideas how I should write the command for it to work properly?

Hi Miki,

You could try this

rule "When this item ON then other item ON"
    Item itemname changed from OFF to ON
    itemname.sendCommand (ON)

underneath the itemname.sendCommand (ON) you can add more devices as well

Hi Miki,
rf_control.sendCommand(bedroom_fan_1) means that bedroom_fan_1 is a variable (var).
If bedroom_fan_1 is the map command as I suppose should be written between “”
i.e. rf_control.sendCommand(“bedroom_fan_1”) or sendCommand(rf_control , “bedroom_fan_1”)
Let’s try.

1 Like

Thank you, @ciscomike
I indeed used this form of rule.
As @Foxejoe suggested, my problem was I didn’t write the command bedroom_fan_1 within " " (I should have wrote it like this: sendCommand(rf_control , "bedroom_fan_1") .
This solved the problem :slight_smile:

Thanks, Lorenzo :)))
Your suggestion solved the problem :pray: :pray: :pray:

Anyone tested with OH3? I assume we can add the 2.5 jar into the addons folder?

No that won’t work - it has to be an OH3 specific JAR file.

Damn :frowning: guess ill have to wait for an OH3 version

1 Like

I’m also looking forward for the OpenHAB 3 broadlink binding as I have quite a lot of dependency on the RM3 Pro

In the mean time, If you still have an old spare raspi you can have OpenHAB 2.x running with the working 2.5 broadlink binding and just the broadlink items, and access them through 3.0 “remote OpenHAB” binding. It works like a charm!!!

This is what I am doing. Using my pihole / media server RPi for oh2.5and broadlink. works a treat.

Lot of us are waiting for that… I’ve also postponed my plan to move to OH3 until Broadlink binding is solved.

1 Like