Broadlink binding for RMx, A1, SPx and MP. Any interest?


(Carlos Roa) #429

Tell me more about this python script. Is is possible to control SP3 sockets with it? how does it work and where can I find it?


(Greg Smith) #430

I’m coming late to the party and want to get a WiFi IR/RFblaster up and connected to OH…

Likewise, I am considering an RM pro + to integrate IR and RF to my OH setup, but based on this extensive thread it is difficult to ascertain if this is a wise choice. Input as to the utility of this binding at this point in time from current users is much appreciated.


(Mohammad Chaaban) #431

hi, you mean removing the mapping from sitemap?.. can u show me example… the issue happens when u have two broadling devices… r u still facing the issue?.


(Mohammad Chaaban) #432

check below:


(Guillermo Schimmel) #433

Worked great!

I’m learning the codes with davorf scripts.

Thanks guys.


(Carlos Roa) #434

Thanks a lot!!!


(Tony De La Rosa) #435

The following is my broadlink configuration

Item Entries

String BroadlinkPro "Broadlink Pro" {channel="broadlink:rm2:34-ea-34-8e-fe-aa:command" }
String BroadlinkRM3 "Broadlink Mini" {channel="broadlink:rm3:34-ea-34-43-cb-a5:command" }
Switch KITCHEN_TV_POWER "Kitchen TV" [ "Switchable" ]
Switch LR_STEREO_POWER "Den Stereo" [ "Switchable" ]

Sitemap Entries

  Switch item=KITCHEN_TV_POWER
  Switch item=LR_STEREO_POWER

Broadlink Rules

rule "Kitchen TV Power"
when
	Item KITCHEN_TV_POWER changed
then
	BroadlinkPro.sendCommand("KitchenTVPower")
end

rule "Den Stereo Power"
when
	Item LR_STEREO_POWER changed
then
	if (LR_STEREO_POWER.state == ON)
	{
		BroadlinkRM3.sendCommand("LRStereoPowerON")
	}else if (LR_STEREO_POWER.state == OFF)
	{
		BroadlinkRM3.sendCommand("LRStereoPowerOFF")
	}
end

(Mohammad Chaaban) #436

thanks a lot…


(Gad Ofir) #437

anyone is able to use two RMx?

i am getting offline on one all the time


(Mohammad Chaaban) #438

ya… i have this issue also… im trying the workaround in post “426”… ill share the result with u all…


(Mohammad Chaaban) #439

unfortunately same issue…


(Geoff) #440

Hi Guys. I have 3 RM3 Pro. I am getting some offline. Two things I have done which seem to help are

  1. Disable temperature and just leave the control enabled.
  2. Change the polling to 300 or 600. I have used things like 617 618 619 so they are all not polled at the same time.

The broadlinks are good and the binding is great but it seems as if @Cato_Sognen is not returning. So access to source code and improvements are not possible.

I use this to control 3 tvs, fans, apple tv, set top boxes, amps, bluray. I have this working thru ifttt and google home for voice commands. Watching closely and using the google home action for turning lights on and off. Eagerly waiting for the functionality to change volume and channels without needing ifttt.


(Nakh Home) #441

you are right . that’s why i have moved to this project

i can control RM2, RM mini, TC2, SP2, M1 and IR


(Elie Hanna) #442

Hey all,

The binding is great and working normally just like @rednep said that you should increase the polling interval and separate the value of each Broaldink item.

However, i am facing a weired issue in the Android app (the IOS app is working fine). the issue is that the value number of mapping is showing in the interface.

Please help, you can find the picture below to get what i mean. You will see the TV_Ch_2 showing next to the the item. and if i click Channel 1 it will change to TV_Ch_1 so how i can hide the mapping value in the “broadlink.map file” next to the item? And again this issue is only in Android app.

Thank you in advance


(Jordi) #443

Hi,

You need put [].

Exemple:
Switch item=Harmony_Activity label=“TV[]” icon=“screen” mappings=[PowerOff=“Off”, PC=“PC”, TV=“TV”, PS4=“PS4”, OpenHab=“RPi”]

Regards


(Elie Hanna) #444

Thank you, Done !!


(Hartmut Schwensen) #445

I have successfully installed the binding and it is connected with my RM2 (pro). So far so good. Furthermore I installed the Android, entered the IP and the ports which populated step two with rm2 and the mac address.

Nevertheless I have troubles to learn the code in steps 3 of the RM Bridge Code learning page. Shortly after starting I receive the message:

Error learning code: mac:78:0F:77:00:xx:xx not rm2

What might be wrong?


(Gad Ofir) #446

what can i do if have two and thay are alwys going offline ?


(Jordi) #447

Same error


(Hartmut Schwensen) #448

I switched to the python script which worked for me after fixing line #167 in the code.