Broadlink binding for RMx, A1, SPx and MP. Any interest?


(Makram BouGhannam) #512

Is anyone facing problems with connection to broadlink Mini RM3 lately?
I started using the binding about 2 weeks ago and it worked great until yesterday. Now, it seems that OpenHAB is unable communicate with the RM3 although it is showing as Online in the things. Any ideas ?


(Stefan) #513

I’m not sure if it’s already mentioned in this topic, but it seems someone has picked up development for this binding.


(Holger OpenhabUser) #514

This sounds very good! So hopefully we will have a supported binding in the future for these nice devices.


(Nakh Home) #515

No update on this project since 3 months


(Kris K) #516

Can someone help? the THING says it needs a Key and Auth code… theres no instructions on how to get it

To make life easy for people

here it is:

Key = 097628343fe99e23765c1513accf8b02

Vector =562e17996d093d28ddb3ba695a2e6f58


(Stefan) #517

Did anyone manage to transform these words in values? Eg. what is good air quality in VOC?


(Kris K) #518

When configuring the item which has the command, does it have to be a string or can it be a switch?

When i change it to switch I get an error:

12:46:03.611 [WARN ] [.rest.core.internal.item.ItemResource] - Received HTTP POST request at ‘items/Heater’ with an invalid status value ‘HeaterOn’.


(Eusblh) #519

The item entry is a String, the sitemap entry is a Switch. The values given in the mappings of the sitemap entry must match the entry in the map file. (typically broadlink.map in these examples).

if you’re still having trouble, please reply and provide the related entries in these 3 files.


(Kris K) #520

Its OK, it works fine :slight_smile:


(Kris K) #522

Has anyone used the RM Mini to successfully send multiple IR commands? The creators of my Hisense N7 TV in their infinite wisdom believed they would use a menu to access the HDMI ports and not use discrete buttons.

So, to change my HDMI port from one to another I need to go into the menu, across and then hit OK for example.

I’m wondering how I could accomodate this to create a button in HabPanel and a rule to do this.


(Ed Arellano) #523

uh can someone make a youtube vid on how to get this up on a windows setup
?


(Ramz) #524

‘recently’ several people have written that they downloaded the file and put it in add ins folder but can’t see the binding. I don’t remember seeing any satisfactory answer or help.

there’s a tl;dr version at the bottom of this post.

I had the same problem. However I have added other bindings to the addons folder before and had them picked up ok. So after the obligatory restarting of openhab with it not working I got to thinking what if this was an attack vector. Fake binding and people who in on it spreading fake working comments :slight_smile: so I looked at the file and saw it was an html file with a .jar extension. I was downloading on a mobile device but I had downloaded both Cato’s and mgw’s one and both were html files (of dropbox and git). Something had gone wrong in the downloading but without looking at the file contents it wasn’t obvious. No wonder the binding didn’t show up. I took special care to download and checked the contents and in the end it all works.

Posting this in case others are scratching their heads as to why it is not showing up in bindings after being put into the addons directory.

tl;dr version
binding was being downloaded with the correct name but wrong contents so openhab wouldn’t recognise it. downloaded correctly it works fine.


(The Squid) #525

Mind putting links to the files you downloaded please?


(Ramz) #526

mgw’s one (and one I’m using) https://github.com/themillhousegroup/openhab2-addons/blob/master/addons/binding/org.openhab.binding.broadlink/original-jar/org.openhab.binding.broadlink-2.2.0-BETA2.jar


(Ramz) #527

@Cato_Sognen ‘s one: Broadlink binding for RMx, A1, SPx and MP. Any interest?


(Eduardo Robles) #528

@Roby_W
Hi, double check that you have already installed the Map Transformation addon.
Cheers,
Eduardo


(Makram BouGhannam) #529

Hi guys,
I’m having troubles while using the binding. It works fine for some time then suddenly the commands stops working and i have to reset the RM mini 3 and add the THING again. Anyone had such issues ? Is there a solution ?


(The Squid) #530

Hello All -

I need some help learning a remote code and all I really need to learn is one code.

I have received my RM3 and have the binding and transformation service all set, the map file is in place.

My challenge is getting the code to turn my VIZIO TV on or off.

I have attempted to use the site provided originally by CATO above

http://rm-bridge.fun2code.de/rm_manage/code_learning.html

Yet when I try and enter either the iP or MAC address I see a 404 ERROR in the upper right hand corner of the page.

So does anyone have a way of learning the IR code? I can find the HEX of the code in many different places, yet no way to convert it into something that the Broadlink device can use.

Your help would be greatly appreciated.

Squid


(Makram BouGhannam) #531

Hi KidSquid,
you have to add the RM3 manually. Follow these steps:

  1. Download the mobile app RM Bridge on your phone
  2. the app will generate a URL with a port. Use this URL in the RM Bridge website in the Step 1
  3. Fill a Name for you device (anything) then fill the device’s MAC address then in the TYPE write RM3
  4. Click on add manually and you should be set

(Ramz) #532

For my setup this is what I have and need:

python-broadlink library
locate.py learn.py and playcode.py scripts (updated with my RM2 details)
broadlink link binding
physical IR or RF controls

I run the learn python script in a command line to learn the codes: run script, RM2 goes into learning mode, I point the physical remote very near the RM2 and press the button, and the script saves the received code to a text file.

I use the playcode python script to test it works.

I put the received code from learned code text file into the broadlink map file so the binding can use it.

As this thread now has so many posts I planned on doing a tutorial but it will take a while since I have other items in my backlog and there’s several ways to get this all working and I want to capture them all. For example, the python-broadlink library includes its own CLI commands for learning, there’s a python library that offers an http api to learn codes (need to test), and a way to get codes from the Broadlink mobile app (needed so I can set up the TC2 switch).